POJ 1504 Adding Reversed Numbers(我的水题之路——逆向数高精度加法)

Adding Reversed Numbers
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11366 Accepted: 6323

Description

The Antique Comedians of Malidinesia prefer comedies to tragedies. Unfortunately, most of the ancient plays are tragedies. Therefore the dramatic advisor of ACM has decided to transfigure some tragedies into comedies. Obviously, this work is very hard because the basic sense of the play must be kept intact, although all the things change to their opposites. For example the numbers: if any number appears in the tragedy, it must be converted to its reversed form before being accepted into the comedy play. 

Reversed number is a number written in arabic numerals but the order of digits is reversed. The first digit becomes last and vice versa. For example, if the main hero had 1245 strawberries in the tragedy, he has 5421 of them now. Note that all the leading zeros are omitted. That means if the number ends with a zero, the zero is lost by reversing (e.g. 1200 gives 21). Also note that the reversed number never has any trailing zeros. 

ACM needs to calculate with reversed numbers. Your task is to add two reversed numbers and output their reversed sum. Of course, the result is not unique because any particular number is a reversed form of several numbers (e.g. 21 could be 12, 120 or 1200 before reversing). Thus we must assume that no zeros were lost by reversing (e.g. assume that the original number was 12).

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line with two positive integers separated by space. These are the reversed numbers you are to add.

Output

For each case, print exactly one line containing only one integer - the reversed sum of two reversed numbers. Omit any leading zeros in the output.

Sample Input

3
24 1
4358 754
305 794

Sample Output

34
1998
1

Source


题中将给出n组数据,这些数的个位到最高位是倒着给出的,要求你将这些数正过来,之后进行加法运算,然后再用逆向数的方法输出其相加之和。

第一开始那道题,想到的是通过,数字转换成字符串,再用字符串转向数字的方法求解,不过后来想了想这样就和之前做的1350的题目用的相同的方法,想熟悉一下其他方法,于是就想到直接用高精度加法相同的方法来进行这道题的逆向数字的运算。写的过程中还算是比较顺利。

注意点:
1)在输出结果的时候,需要把和的逆序数的前导0去掉。
2)在每一个用例处理之前需要初始化。

代码(1AC):
#include <cstdio>
#include <cstdlib>
#include <cstring>

char num1[10], num2[10], result[10];

int main(void){
    int casenum, ii;
    int i, j;
    int len1, len2;
    int tmp,jinwei;

    scanf("%d", &casenum);
    for (ii = 0; ii < casenum; ii++){
        memset(result, 0, sizeof(result));
        memset(num1, 0, sizeof(num1));
        memset(num2, 0, sizeof(num2));
        scanf("%s%s", num1, num2);
        len1 = strlen(num1);
        len2 = strlen(num2);
        for (i = jinwei = 0; i < len1 && i < len2; i++){
            tmp = (num1[i] - '0') + (num2[i] - '0') + jinwei;
            result[i] = '0' + tmp % 10;
            jinwei = tmp / 10;
        }
        for (; i < len1; i++){
            result[i] += '0' + (num1[i] - '0' + jinwei) % 10;
            jinwei = (num1[i] - '0' + jinwei) / 10;
        }
        for (; i < len2; i++){
            result[i] += '0' + (num2[i] - '0' + jinwei) % 10;
            jinwei = (num2[i] - '0' + jinwei) / 10;
        }
        if (jinwei){
            result[i++] = '0' + jinwei;
        }
        result[i] = '\0';
        int flag = 0;
        int len3 = strlen(result);
        for (i = 0; i < len3; i++){
            if (result[i] == '0' && flag == 0){
                continue;
            }
            else{
                if (!flag){
                    flag = 1;
                }
                printf("%c", result[i]);
            }
        }
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值