POJ 1656 Counting Black(我的水题之路——表格涂色)

Counting Black
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8499 Accepted: 5469

Description

There is a board with 100 * 100 grids as shown below. The left-top gird is denoted as (1, 1) and the right-bottom grid is (100, 100). 

We may apply three commands to the board: 
1.	WHITE  x, y, L     // Paint a white square on the board, 

                           // the square is defined by left-top grid (x, y)

                           // and right-bottom grid (x+L-1, y+L-1)



2.	BLACK  x, y, L     // Paint a black square on the board, 

                           // the square is defined by left-top grid (x, y)

                           // and right-bottom grid (x+L-1, y+L-1)



3.	TEST     x, y, L    // Ask for the number of black grids 

                            // in the square (x, y)- (x+L-1, y+L-1) 

In the beginning, all the grids on the board are white. We apply a series of commands to the board. Your task is to write a program to give the numbers of black grids within a required region when a TEST command is applied. 

Input

The first line of the input is an integer t (1 <= t <= 100), representing the number of commands. In each of the following lines, there is a command. Assume all the commands are legal which means that they won't try to paint/test the grids outside the board.

Output

For each TEST command, print a line with the number of black grids in the required region.

Sample Input

5
BLACK 1 1 2
BLACK 2 2 2
TEST 1 1 3
WHITE 2 1 1
TEST 1 1 3

Sample Output

7
6

Source


有一个100*100的方格,对其进行N次操作,操作类型分为BLACK、WHITE、TEST三种。如果是BLACK,就将(x, y)到(x+l-1,y+l-1)之间的区域变成黑色,如果是WHITE,则让其为白色,如果是TEST,就计算这个区域内有多少个黑色方块,并且输出。

由于数据给的弱,所以用的方法是暴力模拟

注意:
1)如果是高数据,这种方法会TLE,可以使用二维线段树进行涂色功能。

代码(1AC):
#include <cstdio>
#include <cstdlib>
#include <cstring>

int count[110][110];

int main(void){
    int casenum ,ii;
    char oprator[10];
    int x, y, l;
    int i, j;
    int num, value;

    while (scanf("%d", &casenum) != EOF){
        getchar();
        memset(count, 0, sizeof(count));
        for (ii = 0; ii < casenum; ii++){
            scanf("%s%d%d%d", oprator, &x, &y, &l);
            getchar();
            if (!strcmp(oprator, "TEST")){
                value = -1;
                num = 0;
            }
            else if (!strcmp(oprator, "WHITE")){
                value = 0;
            }
            else if (!strcmp(oprator, "BLACK")){
                value = 1;
            }
            for (i = x; i <= x + l - 1; i++){
                for (j = y; j <= y + l - 1; j++){
                    if (value == -1){
                        if (count[i][j] == 1){
                            num ++;
                        }
                    }
                    else{
                        count[i][j] = value;
                    }
                }
            }
            if (value == -1){
                printf("%d\n", num);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值