POJ 3386 Halloween Hoildays(我的水题之路——两个戒指)

Halloween Holidays
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2787 Accepted: 1120

Description

Planet Cucurbita is inhabited with intelligent pumpkins. These pumpkins are not only extremely clever, they also are fond of tourism. One of their main routes is the Earth during Halloween.

As you know, pumpkins cannot move by themselves (intelligent pumpkins are not an exception), so they make somebody else to transport them. In the case of Halloween this is done by humans. First, they make people to grow special biological docking stations, then prepare the stations (people cut special holes, fire candles etc – you know the procedure), and after these preparations pumpkins come and have fun. People usually do not see anything and think that this is just a holiday and that this holiday is for humans, but remember – if somebody is frightened at Halloween, he was frightened not by his not-very-friendly friends, but by alien pumpkins.

To use the biological docking station, a pumpkin must have a special transmitter. It’s main elements are two rings made of gold and for some unexplainable reasons these rings should be cut from one round plate. The sizes of these rings (inner and outer radii) are pumpkin-specific, so each alien should order a special set for himself.

Mr. Calabaza, an adolescent pumpkin, wants to make his first trip to the Earth. He found a discount plate, which was not redeemed by a previous customer, and it is necessary to check, whether this plate allows Mr. Calabaza to cut the rings he needs from it, or he should order a new larger plate.

Input

The input file contains five integer numbers AaBbP (0 < AaBbP ≤  1 000 000 , a < A and b < B), separated with spaces. Here, A and B are the outer radii of the rings, a and b are the inner radii of the corresponding rings, and P is the plate radius.

Output

Output a word “Yes” if the plate suits Mr. Calabaza, or a word “No” if he needs to order another one.

Sample Input

2 1 5 3 6

Sample Output

Yes

Hint

Source

Northeastern Europe 2006, Northern Subregion

需要在一个半径为P的金盘上扣下两个圆环做戒指,两个戒指的外半径分别为A、B,内半径分别为a、b。问是否可以在这个金盘上得到这两个戒指。

根据Hint里的图,知道两个戒指是套在一起的,所以只需要比较是否里面戒指的外半径小于外部戒指的内半径,外部戒指的外半径是是否小于金盘外半径,或者,两个外半径相加小于金盘半径(两个戒指并排)。

代码(1AC):
#include <cstdio>
#include <cstdlib>

int main(void){
    int A, a, B, b, P;

    while (scanf("%d%d%d%d%d", &A, &a, &B, &b, &P) != EOF){
        if (A <= b && B <= P || B <= a && A <= P || A + B <= P){
            printf("Yes\n");
        }
        else{
            printf("No\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值