Brackets 括号匹配(POJ - 2955)区间dp

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

 这道题的意思单看实例就显而易见, 就是求括号的最大匹配;这个时候就需要用到区间匹配了;

dp[ i ][ j ] 指的就是在 i 到 j 这个区间里的最大值,;

如果区间存在【】或者()即 i 和 j 发生匹配,此时的 dp[ i ][ j ] = dp[ i + 1 ] [ j  - 1 ] + 2 ;

然后更新dp[ i ][ j ]区间内所有可能更新的变量

for ( int k = i ; k <  j ; k ++ )

dp[ i [ j ] = max ( dp[ i ] [ j ] , dp[ i ][ k ] , dp[ k + 1 ] [ j ] );

然后就是控制 i 和 j 之间的距离了,因为要更新最大值所以 i 的值会随时变换,从小到大,更新完后,还要从小到大再次进行更新,所以 控制 i 和 j 之间的距离 是循环的最外层;

代码如下;

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
char a[1001];
int dp[1010][1010];
void slove()
{
	int l=strlen(a);
	memset(dp,0,sizeof(dp));
	for(int i=1;i<l;i++)
	{
		for(int j=0;j+i<l;j++)
		{
			int k=j+i;
			if((a[j]=='('&&a[k]==')')||(a[j]=='['&&a[k]==']'))
			dp[j][k]=dp[j+1][k-1]+2;
			for(int z=j;z<k;z++)
			{
				dp[j][k]=max(dp[j][z]+dp[z+1][k],dp[j][k]);
			}
			
		}
	}
	printf("%d\n",dp[0][l-1]);
}
int main()
{
	while(~scanf("%s",a))
	{
		if(a[0]=='e')
		break;
		slove();
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值