Cash Machine(多重背包)

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

 这个题目的意思是说给出一个钱数n,然后又给出不同面额钱币的种类k,

然后又给出k组数,每组面额钱币的个数和价值,

将这些钱能尽量组合接近当初给的钱数,问组成的钱为多少?

这个问题就是一个多重背包,不过,由于数据太大,将其转换为0-1背包。

将每组面额钱币的个数拆开,足称不同的面额按照2的倍数拆,从1、2、4、8.。。。这样拆。最后不满足的那个数自分一组。这样拆开后会少一个for循环,复杂度降低。这样子种类会增加,但每组面额的个数变为了一,(基数又可能变为二),这样拆不会使它们组合成的数有变化,

题意中4个125,可以拆为  1个125,1个250,剩一个125,如果按商品理解的话,理解为3个商品。

代码:

#include<stdio.h>
#include<string.h>
int max(int x,int y)
{
    return x>y?x:y;
}
int s[30001],a,b;
int dp[100100];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp,0,sizeof(dp));
        int g=0;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&a,&b);
            int x=1;
            while(x<a)
            {
                s[g++]=x*b;
                a-=x;
                x*=2;
            }
            if(a)
                s[g++]=a*b;
        }
        for(int i=0; i<g; i++)

            for(int k=n; k>=s[i]; k--)
            {
                dp[k]=max(dp[k],dp[k-s[i]]+s[i]);
            }
        printf("%d\n",dp[n]);
    }
    return 0;

}

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值