Cash Machine 多重背包

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 … nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input
735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10
Sample Output
735
630
0
0
Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

题意:
一个人要去取钱,取得钱数为n,现在告诉你ATM取款机一共有几种钞票,并且给出每种钞票的面额以及个数;求出ATM能吐出不大于n的最大的钱数是多少;

思路:
我是这样想的,既然给定了每种钞票的价值以及个数,那不就是多重背包么。但是多重背包的背包容量是多少呢;可以把n看成背包容量,也就是用这些钞票,组成一个钱数s,要小于背包的容量n;那么每种钞票的价值又可以同时看作是重量,往背包里面放,看最多能放多少钱;

AC代码:

#include <iostream>

using namespace std;
const int maxx=1e5+7;
int v[maxx];
int w[maxx];
int m[maxx];
int dp[maxx];
void init()
{
    for(int i=0;i<maxx;i++)
    {
        v[i]=0;
        w[i]=0;
        m[i]=0;
        dp[i]=0;
    }
}
int main()
{
    int n,kk;
    while(cin >>n>>kk)
    {
        init();
        for(int i=0;i<kk;i++)
        {
            cin>>m[i]>>v[i];
            w[i]=v[i];
        }
        for(int i=0;i<kk;i++)
        {
            int num=m[i];
            for(int k=1;num>0;k<<=1)
            {
                int mul=min(k,num);
                for(int j=n;j>=w[i]*mul;j--)
                {
                    dp[j]=max(dp[j],dp[j-w[i]*mul]+v[i]*mul);
                }
                num-=mul;
            }
        }
        cout <<dp[n]<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值