poj2386 poj3620

2386.Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14109 Accepted: 7179

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Source

#include <stdio.h>
#include<memory.h>
char a[111][111];
int m,n,f;
void dfs(int i,int j)
{
    if(a[i][j]=='.'||i<0||j<0||i>m-1||j>n-1) return ;
    a[i][j]='.';
    dfs(i,j+1);
    dfs(i,j-1);
    dfs(i+1,j);
    dfs(i+1,j-1);
    dfs(i+1,j+1);
    dfs(i-1,j);
    dfs(i-1,j+1);
    dfs(i-1,j-1);
}
int main()
{
    scanf("%d%d",&m,&n);
    f=0;
    memset(a,0,sizeof(a));
    for(int i=0;i<m;i++)
        scanf("%s",a[i]);
    for(int i=0;i<m;i++)
        for(int j=0;j<n;j++)
        {
            if(a[i][j]=='W')
            {
                f++;
                dfs(i,j);
            }
        }
    printf("%d\n",f);
    return 0;
}

3620.Avoid The Lakes
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5347 Accepted: 2865

Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactlyK (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: NM, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4

Source


判断上下左相通的cell的个数的max,DFS
#include <cstdio>
#include <iostream>
#include <memory.h>
using namespace std;
int a[110][110],vis[110][110];
int n,m,k;
int dfs(int i,int j)
{
    if(i<1||j<1||i>n||j>m||vis[i][j]!=0||a[i][j]==0)
    return 0;
    vis[i][j]=1;
    int t=1;
    t+=dfs(i-1,j);
    t+=dfs(i+1,j);
    t+=dfs(i,j+1);
    t+=dfs(i,j-1);
    return t;
}
int main()
{
    while(scanf("%d%d%d",&n,&m,&k)!=EOF)
    {
        int i,j,p,q,max;
        memset(a,0,sizeof(a));
        memset(vis,0,sizeof(vis));
        max=0;
        for(i=0;i<k;i++)
        {
            scanf("%d%d",&p,&q);
            a[p][q]=1;
        }
        for(i=1;i<=n;i++)
        for(j=1;j<=m;j++)
        if(a[i][j]&&!vis[i][j])
        {
            int sum=dfs(i,j);
            if(sum>max)
            max=sum;
        }
        printf("%d\n",max);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值