poj 2488 A Knight's Journey

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20955 Accepted: 7087

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

哎呀呀。。。英语不好,题目理解错误。。。把字典序的坐标当成了行坐标。。。然后dfs边界里面定义就错了。。苦WA了n次。。。虽然说是dfs入门ing,但这状况不行啊,还是要提高效率的说。

#include <iostream>
#include <stdio.h>
using namespace std;
int map[27][27];
int path[27][2];
int dir[8][2]={-2,-1,-2,1,-1,-2,-1,2,1,-2,1,2,2,-1,2,1};
int a,b,flag,n,k;
void dfs(int i,int j,int step)
{
    if(step==a*b)
    {
        for(int i=0;i<step;i++)
        printf("%c%d",path[i][0]+'A',path[i][1]+1);
        printf("\n");
        flag=1;
    }
    else
    {
        for(int x=0;x<8;x++)
        {
            int n=i+dir[x][0];
            int m=j+dir[x][1];
            if(m>=0&&n>=0&&n<b&&m<a&&!flag&&!map[n][m])
            {
                map[n][m]=1;
                path[step][0]=n;
                path[step][1]=m;
                dfs(n,m,step+1);
                map[n][m]=0;
            }
        }
    }
}
int main()
{
    k=1;
    scanf("%d",&n);
    while(n--)
    {
        flag=0;
        scanf("%d%d",&a,&b);
        for(int i=0;i<a;i++)
        for(int j=0;j<b;j++)
        map[i][j]=0;
        map[0][0]=1;
        path[0][1]=0;
        path[0][0]=0;
        cout<<"Scenario #"<<k++<<":"<<endl;
        dfs(0,0,1);
        if(!flag)
        cout<<"impossible"<<endl;
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值