hdu 4272 LianLianKan

LianLianKan

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 716    Accepted Submission(s): 251


Problem Description
I like playing game with my friend, although sometimes looks pretty naive. Today I invent a new game called LianLianKan. The game is about playing on a number stack.
Now we have a number stack, and we should link and pop the same element pairs from top to bottom. Each time, you can just link the top element with one same-value element. After pop them from stack, all left elements will fall down. Although the game seems to be interesting, it's really naive indeed. 

To prove I am a wisdom among my friend, I add an additional rule to the game: for each top element, it can just link with the same-value element whose distance is less than 6 with it. 
Before the game, I want to check whether I have a solution to pop all elements in the stack.
 

Input
There are multiple test cases.
The first line is an integer N indicating the number of elements in the stack initially. (1 <= N <= 1000)
The next line contains N integer ai indicating the elements from bottom to top. (0 <= ai <= 2,000,000,000)
 

Output
For each test case, output “1” if I can pop all elements; otherwise output “0”.
 

Sample Input
  
  
2 1 1 3 1 1 1 2 1000000 1
 

Sample Output
  
  
1 0 0
 

Source
 

Recommend
liuyiding
 

#include <stdio.h>
#include <string.h>
long long a[1010];
int flag[1010];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(flag,0,sizeof(flag));
        for(int i=1;i<=n;i++)
        scanf("%I64d",&a[i]);
        int p;
        int tag=0;
        int move;
        for(int i=2;i<=n;i++)
        {
            if(!flag[i])
            {
                move=1;
                int j;
                for(j=i-1;;j--)
                {
                    if(!flag[j])
                    break;
                }
                for(;;j--){
                    if(!flag[j]&&a[i]==a[j])
                    {
                        flag[i]=1;
                        flag[j]=1;
                        break;
                    }
                    if(!flag[j])
                    {
                        move++;
                    }
                    if(move==5)
                    break;
                }
            }
        }
        for(int i=1;i<=n;i++)
        if(flag[i]==0)
        {
            tag=1;
            break;
        }
        if(tag)
        printf("0\n");
        else
        printf("1\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值