hdu 3835 R(N)

R(N)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1406    Accepted Submission(s): 725


Problem Description
We know that some positive integer x can be expressed as x=A^2+B^2(A,B are integers). Take x=10 for example,  
10=(-3)^2+1^2.
We define R(N) (N is positive) to be the total number of variable presentation of N. So R(1)=4, which consists of 1=1^2+0^2, 1=(-1)^2+0^2, 1=0^2+1^2, 1=0^2+(-1)^2.Given N, you are to calculate R(N).
 

Input
No more than 100 test cases. Each case contains only one integer N(N<=10^9).
 

Output
For each N, print R(N) in one line.
 

Sample Input
  
  
2 6 10 25 65
 

Sample Output
  
  
4 0 8 12 16
Hint
For the fourth test case, (A,B) can be (0,5), (0,-5), (5,0), (-5,0), (3,4), (3,-4), (-3,4), (-3,-4), (4,3) , (4,-3), (-4,3), (-4,-3)
 

Source
 

Recommend
xubiao
 


 

唉。。。闲得蛋疼的不知名的公式?

百度了一下,貌似这个公式不存在

不过还是用着吧,管它怎么来的

勒让德两平方数之和定理:R(N)=4*D1(N)-4*D3(N)

D1(N)=(整除且满足d=1(mod 4)的正约数的个数),

D3(N)=(整除且满足d=3(mod4)的正约数的个数)

找到一个相关的定理,费马平方和定理。。。凑合着看吧

http://zh.wikipedia.org/zh/费马平方和定理

 

#include <stdio.h>
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int d1=0,d2=0;
        for(int i=1;i*i<=n;i++)
        if(n%i==0)
        {
            if(i%4==1)
            d1++;
            else if(i%4==3)
            d2++;
            if(n/i==i)
            break;
            else
            {
                int a=n/i;
                if(a%4==1)
                d1++;
                else if(a%4==3)
                d2++;
            }
        }
        printf("%d\n",4*(d1-d2));
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值