hdu 2837 Calculation

Calculation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 885    Accepted Submission(s): 195


Problem Description
Assume that f(0) = 1 and 0^0=1. f(n) = (n%10)^f(n/10) for all n bigger than zero. Please calculate f(n)%m. (2 ≤ n , m ≤ 10^9, x^y means the y th power of x).
 

Input
The first line contains a single positive integer T. which is the number of test cases. T lines follows.Each case consists of one line containing two positive integers n and m.
 

Output
One integer indicating the value of f(n)%m.
 

Sample Input
  
  
2 24 20 25 20
 

Sample Output
  
  
16 5
 

Source
 

Recommend
gaojie
 


一看AC人数,就不敢暴力了,想了想,这个题应该是有公式的,想了半天,想不通,看了下discuss,果然与欧拉函数有关系,而且是赤裸裸的公式:

[定理]A^x % m = A^(x%phi(m)+phi(m)) % m (x >= phi(m))

discuss 写的蛮好,不多说了:
1)在求a^b^c % m 的时候,递归求b^c % phi(m),如果c很大是得b^c>=phi(m),那么原式应该=a^(b^c % phi(m) + phi(m)) % m, 但是取余后的c(用c'表示)可能很小使得b^c' < phi(m),很多代码(可能标程在内)只是判断当前这层,如上例的话 b^c' < phi(m) 所以有的代码就不加 phi(m)了,事实上应该加上phi(m),如果 b^c >= phi(m)的话;但是神奇的是这题的1000组数据,只判当前也是对的。
2)那到底怎么判断到底加不加模数呢? 提出假设:如果x >= phi(m),则 a^x >= m (a > 1)。假设不成立,那么存在x >= phi(m)且 a^x < m (a > 1), 则存在 2^phi(m) < m (a取2),确实存在如m=6,phi(6)=2,2^phi(6) < 6,但是ONLY只有6,所以只需特判即可。所以有定理如果x >= phi(m), a^x >= m (a > 1 && not(a==2&&x==2&&m==6[注意x是真实值]));那么只要有一层超出了模数,那么之前的都要加上模数!;但是此题不加特判也能AC。

去百度找了找,貌似是个没名字的定理,喵呜给了个链接,http://hi.baidu.com/aekdycoin/item/e493adc9a7c0870bad092fd9,心情不是很好,看不进去,证明想看的话再看吧,公式还是先记住... 关于那个指数循环节,中间有涉及到SPOS(A,C)的另一算法,链接是:http://hi.baidu.com/aekdycoin/item/534c3ccd0a977e0dc710b2d8


// A^x % m = A^(x%phi(m)+phi(m)) % m 
// sure (x >= phi(m))
//
#include <stdio.h>
#include <math.h>
long long powmod(long long a,long long b,long long mod)
{
    long long res=1;
    while(b)
    {
        if(b%2==1)
            res=res*a%mod;
        b>>=1;
        a=(a*a)%mod;
    }
    return res;
}
long long euler(long long x)
{
    long long res=x;
    for(long long i=2;i<(int)sqrt(x*1.0)+1;i++)
        if(x%i==0)
        {
            res=res/i*(i-1);
            while(x%i==0)
                x/=i;
        }
    if(x>1)
        res=res/x*(x-1);
    return res;
}
long long miao(int a,int b,int mod)
{
    long long res=1;
    for(long long i=1;i<=b;i++)
    {
        res*=a;
        if(res>=mod) return res;
    }
    return res;
}
long long fun(long long n,long long m)
{
    long long num=euler(m);
    if(n<10)
        return n;
    long long a=fun(n/10,num);
    long long b=miao(n%10,a,m);
    if(b>=m)
    {
        long long res=powmod(n%10,a+num,m);
        if(res==0)
            res+=m;
        return res;
    }
    return b;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int m,n;
        scanf("%d%d",&m,&n);
        printf("%I64d\n",fun(m,n)%n);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值