1081. Rational Sum (20)

1081. Rational Sum (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24
AC代码
#include<iostream>
#include<string>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
class rationalCalc {
public:
    long long  numberator,denoinator;
    rationalCalc(long long a,long long b) {
        numberator =a;
        denoinator =b;
    }
    rationalCalc();
    void operator =(rationalCalc);
    rationalCalc operator +(rationalCalc);
    string print();
};
int main() {
    int n;
    cin>>n;
    rationalCalc sum(0,1);
    string rationalNumA;
    long long numberatorA,denominatorA;
    while(n--){
        cin>>rationalNumA;
        sscanf(rationalNumA.c_str(),"%lld/%lld",&numberatorA,&denominatorA);
        rationalCalc num(numberatorA,denominatorA);
        sum=sum+num;
    }
    printf("%s\n",sum.print().c_str());
    return 0;
}
long long Max_GongYue(long long a,long long b) {
    return b == 0 ? a : Max_GongYue(b, a%b);
}

long long Min_GoneBei(long long a,long long b) {
    return a*b/Max_GongYue(a,b);
}

rationalCalc rationalCalc::operator+(rationalCalc target) {
    long long numberat,denoina,minGongbei;
    minGongbei = Min_GoneBei(denoinator,target.denoinator);
    denoina = minGongbei;
    numberat = minGongbei/denoinator*numberator+minGongbei/target.denoinator*target.numberator;
    return rationalCalc(numberat,denoina);
}
void rationalCalc::operator=(rationalCalc target) {
    numberator = target.numberator;
    denoinator = target.denoinator;
}
string rationalCalc::print() {
    char res1[10];
    string res;
    if(numberator==0)
        return "0";
    long long fenzi = numberator,fenmu = denoinator;
    if(fenmu<0) {
        fenzi = -fenzi;
        fenmu = -fenmu;
    }
    long long gcd = Max_GongYue(abs(fenzi),fenmu);
    fenmu = fenmu/gcd;
    fenzi = fenzi/gcd;
    if(fenmu==1) {
        sprintf(res1,"%lld",fenzi);
        res = res1;
    } else {
        long long partint = fenzi/fenmu;
        fenzi = fenzi%fenmu;
        if(partint!=0) {
            if(partint<0)
                fenzi = -fenzi;
            sprintf(res1,"%lld %lld/%lld",partint,fenzi,fenmu);
        } else
            sprintf(res1,"%lld/%lld",fenzi,fenmu);
        res = res1;
    }
    return res;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值