1086. Tree Traversals Again (25)

本次AC参考了他人代码:http://blog.csdn.net/jmlikun/article/details/50003781

1086. Tree Traversals Again (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
#include <iostream>
#include <string>
#include <cstdio>
#include <vector>
#include <queue>
#include <algorithm>
#include <stack>
using namespace std;
struct Node
{
    int data;
    Node * left;
    Node * right;
    Node():data(0),left(NULL),right(NULL) {};
    Node(int x):data(x),left(NULL),right(NULL) {};
};
void Post(Node *T,vector<int>* o)
{
    if(T->left)
        Post(T->left,o);
    if(T->right)
        Post(T->right,o);
    (*o).push_back(T->data);
}
int main()
{
    int n,num;
    cin>>n;
    string str;
    Node *lastpop=NULL,*root = NULL;
    stack<Node *>sta;
    for(int i=0; i<2*n; ++i)
    {
        cin>>str;
        if(str=="Push")
        {
            cin>>num;
            if(sta.empty()&&lastpop==NULL) //上次没弹出,这次压入,根节点
            {
                root = new Node(num);
                sta.push(root);
            }
            else if(lastpop)  //上次有弹出,这次压入为右节点
            {
                lastpop->right = new Node(num);
                sta.push(lastpop->right);
            }
            else//栈不为空且上次未弹出为压入栈顶元素左子树
            {
                sta.top()->left = new Node(num);
                sta.push(sta.top()->left);
            }
            lastpop = NULL;
        }
        else
        {
            lastpop = sta.top();
            sta.pop();
        }
    }
    vector<int>outt;//输出序列
    Post(root,&outt);
    for_each(outt.begin(),outt.end(),[&](int a)
    {
        static int count = 0;
        cout<<a;
        count++;
        if(count == outt.size())
            cout<<endl;
        else
            cout<<" ";
    });
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值