1086 Tree Traversals Again

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

Figure 1
Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

解题思路:与上一题一样,也是先根据输入构造二叉树然后进行后序遍历进行输出。只是这道题没有明确的给出前序遍历和中序遍历,中序遍历根据题目的输出模仿栈的压入弹出就可以得到,前序遍历的话需要自己想一下,其实就是压栈的顺序就是前序遍历。
所以样例的前序遍历是:1 2 3 4 5 6,中序遍历是:3 2 4 1 6 5

#include<iostream>
#include<stdio.h>
#include<stack>
using namespace std;
struct node{
    int left;
    int right;
};
node tree[35];
int index = 0;
int pre[35];
int in[35];
void post(int *pre, int * in, int pBegin, int pEnd, int iBegin, int iEnd){
    if (pBegin == pEnd || iBegin == iEnd){
        return;
    }
    int iMid = 0;
    for (int i = iBegin; i < iEnd; i++){
        if (in[i] == pre[pBegin]){
            iMid = i;
            break;
        }
    }
    int pMid = iMid - iBegin + pBegin + 1;
    if (pMid > pBegin + 1){
        tree[pBegin].left = pBegin + 1;
    }
    else{
        tree[pBegin].left = -1;
    }
    if (pEnd > pMid){
        tree[pBegin].right = pMid;
    }
    else{
        tree[pBegin].right = -1;
    }
    post(pre, in, pBegin + 1, pMid, iBegin, iMid);
    post(pre, in, pMid, pEnd, iMid + 1, iEnd);
}
void postShow(int root){
    if (root == -1){
        return;
    }
    postShow(tree[root].left);

    postShow(tree[root].right);
    if (index == 0){
        printf("%d", pre[root]);
        index++;
    }
    else{
        printf(" %d", pre[root]);
    }

}
int main(){
    for (int n; scanf("%d", &n) != EOF;){
        stack<int>temp;
        int pIndex = 0;
        int iIndex = 0;
        for (int i = 0; i < n * 2; i++){
            char op[6];
            scanf("%s", op);
            if (op[1] == 'u'){
                scanf("%d", &pre[pIndex]);
                temp.push(pre[pIndex]);
                pIndex++;
            }
            else{
                in[iIndex] = temp.top();
                temp.pop();
                iIndex++;
            }
        }
        index = 0;
        post(pre, in, 0, n, 0, n);
        postShow(0);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值