Tallest Cow

FJ's N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.

FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.

For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

Input

Line 1: Four space-separated integers: N, I, H and R
Lines 2.. R+1: Two distinct space-separated integers A and B (1 ≤ A, BN), indicating that cow A can see cow B.

Output

Lines 1.. N: Line i contains the maximum possible height of cow i.

Sample Input

9 3 5 5
1 3
5 3
4 3
3 7
9 8

Sample Output

5
4
5
3
4
4
5
5
5

题意:有n头牛,告诉你告诉你了牛的最大高度h和最低高度k 和 r 组案列 <A,B>, <A,B> 表示第A头牛能够看见第B头牛(相反B也能够看见A对吧)根据这些案列要你判断每头牛的最大高度。

思路:将所有牛赋值为最高高度h,根据每组案列 将 | A-B|>1的 之间的所有数减1

AC代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<stdio.h>
#include<algorithm>
#include<algorithm>
#include<string.h>
#include <math.h>
#include<map>
using namespace std;
int a[1000000];
pair<int ,int >s[1000000];//这个函数挺好用的,不会的百度,你也可以用结构体。
int main()
{
    int n,i,k,h,r,j;
    int t;
     cin>>n>>k>>h>>r;
     int x,y;
     for(i=1;i<=n;i++)
       a[i]=h;                       //赋值最大高度
        for(i=1;i<=r;i++)
         {
             cin>>s[i].first>>s[i].second;
             if(s[i].first>s[i].second)//编号小的那头牛放在第一元素
             {
                 t=s[i].first;
                 s[i].first=s[i].second;
                 s[i].second=t;
             }
         }
         sort(s+1,s+r+1);//对第一元素排序
         for(i=1;i<=r;i++)
         {
             if(s[i].second-s[i].first==1)
                continue;
            else if(s[i].first==s[i-1].first&&s[i].second==s[i-1].second)//这是个坑要注意多组相同的案列算一种案列就行。
                    continue;
              else
             {
                 for(j=s[i].first+1;j<=s[i].second-1;j++)
                 {
                     a[j]--;
                 }
             }
         }
      for(i=1;i<=n;i++)
      cout<<a[i]<<endl;
    return 0;
}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值