ZOJ 1372 Networking 最小生成树 Kruscal && Prim

ZOJ Problem Set - 1372
Networking

Time Limit: 2 Seconds      Memory Limit: 65536 KB

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.

Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.


Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.

The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.


Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.


Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0


Sample Output

0
17
16
26

注-此题为:ZOJ 1372 Networking 

说明:     最小生成树 Kruscal && Prim  (模板题) 输入的是 编号 和 权值 

已AC代码:(Kruscal )

#include<cstdio>
#include<cstring>
#include<cmath>
#define M 25000
#include<algorithm>
using namespace std;

int per[300];   // 并查集 
int n,m;

struct node{
	int u,v,w;   //w为距离 
}s[M];

bool cmp(node a,node b)
{
	return a.w<b.w;
}

void into()     //初始化 
{
	for(int i=0;i<=n;++i)
		per[i]=i;
}

int find(int x)    // 查找根节点 
{
	return x==per[x]?x:per[x]=find(per[x]);
}

bool join(int a,int b)    //合并根节点,并判断是否成环 
{
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb)
	{
		per[fa]=fb;
		return true;
	}
	return false;
}

int main()
{
	int i,j;
	while(scanf("%d",&n),n)
	{
		scanf("%d",&m);

		for(i=0;i<m;++i)   //读入数据 
			scanf("%d%d%d",&s[i].u,&s[i].v,&s[i].w);
			
		into();   //初始化根节点 
		sort(s,s+m,cmp);    //按距离从小到大排序 
		
		int sum=0;
		for(i=0;i<m;++i)
		{
			if(join(s[i].u,s[i].v))
			{
				sum+=s[i].w;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}

已AC代码:( Prim  

#include<cstdio>
#include<cstring>
#include<cmath>
#define INF 0xfffffff


int n,m,sum;  //sum最小生成树权值和 
int vis[300];    //map二维数组存图,low记录每2个点间最小权值,vis标记某点是否已访问
int map[300][300],low[300];

void prim()
{
	memset(vis,0,sizeof(vis));
	int i,j,pos,t;
	int MIN;
	
	for(i=1;i<=n;++i)  	//从某点开始,分别标记vis和记录该点pos
		low[i]=map[1][i];  	//第一次给low数组赋值 map的第一行 
	vis[1]=1;pos=1;t=0;
	
	for(i=1;i<n;++i)   //再运行n-1次,一次找一个最小 
	{
		MIN=INF;
		for(j=1;j<=n;++j)
		{
			if(vis[j]==0&&low[j]<MIN)
			{
				MIN=low[j];  // 找出最小值min,记录位置pos
				pos=j;
			}
		}
		sum+=MIN;
		vis[pos]=1;   //标记该点已访问 
		for(j=1;j<=n;++j)    //更新权值low 把 map的 pos 行中比对应的 low 小的赋给low 
			if(vis[j]==0&&low[j]>map[pos][j])  
				low[j]=map[pos][j];
	}
}

int main()
{
	int i,j,a,b,c;
	while(scanf("%d",&n),n)
	{
		scanf("%d",&m);
		for(i=1;i<=n;++i) //map初始化 
			for(j=1;j<=n;++j)
				map[i][j]=INF;
				
		for(i=0;i<m;++i)   //读入数据 
		{
			scanf("%d%d%d",&a,&b,&c);
			if(map[b][a]>c)  // map[a][b]与map[b][a]  选择代价小的 
			{
				map[a][b]=map[b][a]=c;
			}
			else
				map[a][b]=map[b][a];
		}

		sum=0;
		prim();
		printf("%d\n",sum);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值