HDOJ 3665 Seaside【Dijkstra】【SPFA】【Floyd】

Seaside

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1435    Accepted Submission(s): 1044


Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.
 

Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers S Mi and L Mi, which means that the distance between the i-th town and the S Mi town is L Mi.
 

Output
Each case takes one line, print the shortest length that XiaoY reach seaside.
 

Sample Input
  
  
5 1 0 1 1 2 0 2 3 3 1 1 1 4 100 0 1 0 1
 

Sample Output
  
  
2
题目链接: HDOJ 3665 Seaside【Dijkstra】【SPFA】【Floyd】

最短路 【Dijkstra】 【SPFA】 【Floyd】

题意:从 0 出发,找一条最短路通往 海边,但是不是每一座城市都临海

此题关键在于理解数据:

题意 : 数据输入第一个是N,然后是N组数据,N个城市,第i组数据第一个是 Mi和Pi,
 Mi代表城市i有多少条边,P代表是否与海边相邻,
然后接下来是MI组数据 每组 两个数 第一个表示城市编号L, i和这个城市相连,
后面的数是DIS,代表L和i的权值。

 
 
5 数据输入第一个是N,然后是N组数据 1 0 城市 0,第1组数据第一个是 M和P,代表城市 0 有 1 条边,P为0代表不与海边相邻 1 1 城市 0 与 城市 1 相连,权值为 1 2 0 城市 1, 第2组数据第一个是 M和P,代表 城市 0 有 2 条边, P为0代表不与海边相邻 2 3 城市 1 与 城市 2 相连,权值为 3 3 1 城市 1 与 城市 3 相连,权值为 1 1 1 城市 2, 第3组数据第一个是 M和P,代表 城市 2 有 1 条边, P为1代表与海边相邻 4 100 城市 2 与 城市 4 相连,权值为 100 0 1 城市 3, 第4组数据第一个是 M和P,代表 城市 3 有 0 条边, P为1代表与海边相邻 0 1 城市 4, 第5组数据第一个是 M和P,代表 城市 4 有 0 条边, P为1代表与海边相邻
已AC代码一:【Dijkstra】

#include<cstdio>
#include<cstring>
#define INF 0x3f3f3f
int map[20][20],vis[20],dist[20],p[20],n;
int min(int x,int y)
{
	return x<y?x:y;
}
void Dijkstra()
{
	int i,j;
	memset(dist,INF,sizeof(dist));
	memset(vis,0,sizeof(vis));
	dist[0]=0;
	while(1)
	{
		j=-1;
		for(i=0;i<n;++i)
		{
			if(vis[i]==0&&(j==-1 || dist[i]<dist[j]))
			{
				j=i;
			}
		}
		if(j==-1)
			break;
		vis[j]=1;
		for(i=0;i<n;++i)
		{
			dist[i]=min(dist[i],dist[j]+map[j][i]);
		}
	}
}

int main()
{
	int i,m,v,w;
	while(scanf("%d",&n)!=EOF)
	{
		memset(map,INF,sizeof(map));
		for(i=0;i<n;++i)
		{
			scanf("%d%d",&m,&p[i]);
			
			while(m--)
			{
				scanf("%d%d",&v,&w);
				map[i][v]=map[v][i]=w;
			}
		}
		Dijkstra();
		int Min=INF;
		for(i=0;i<n;++i)
		{
			if(p[i]==1 && Min>dist[i])
				Min=dist[i];
		}
		printf("%d\n",Min);
	}
	return 0;
}
已AC代码二:【SPFA】

#include<cstdio>
#include<cstring>
#include<queue>
#define INF 0x3f3f3f
#define M 10000
using namespace std;
struct Edge{
	int from,to,val,next;
}edge[M];
int n,cnt,p[M],head[M],dist[M],vis[M];

void addedge(int u,int v,int w)
{
	edge[cnt].from=u;
	edge[cnt].to=v;
	edge[cnt].val=w;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}

void SPFA()
{
	memset(vis,0,sizeof(vis));
	memset(dist,INF,sizeof(dist));
	int i,j;
	dist[0]=0;
	queue<int>Q;
	Q.push(0);
	while(!Q.empty())
	{
		int u=Q.front();
		Q.pop();
		for(i=head[u];i!=-1;i=edge[i].next)
		{
			int v=edge[i].to;
			if(dist[v]>dist[u]+edge[i].val)
			{
				dist[v]=dist[u]+edge[i].val;
				if(vis[v]==0)
				{
					vis[v]=1;
					Q.push(v);
				}
			}
		}
	}
}

int main()
{
	int i,m,v,w;
	while(scanf("%d",&n)!=EOF)
	{
		memset(head,-1,sizeof(head));
		cnt=0;
		
		for(i=0;i<n;++i)
		{
			scanf("%d%d",&m,&p[i]);
			while(m--)
			{
				scanf("%d%d",&v,&w);
				addedge(i,v,w);
				addedge(v,i,w);
			}
		}
		SPFA();
		int Min=INF;
		for(i=0;i<n;++i)
		{
			if(p[i]==1 && Min>dist[i])
				Min=dist[i];
		}
		printf("%d\n",Min);
	}
	return 0;
}
已AC代码三:【Floyd】
#include<cstdio>
#include<cstring>
#define INF 0x3f3f3f
int dist[20][20],p[20],n;
int MIN(int x,int y)
{
	return x<y?x:y;
}
void Floyd()
{
	int i,j,k;
	for(k=0;k<n;++k)
	{
		for(i=0;i<n;++i)
		{
			for(j=0;j<n;++j)
			{
				dist[i][j]=MIN(dist[i][j],dist[i][k]+dist[k][j]);
			}
		}
	}
}
int main()
{
	int i,m,v,w;
	while(scanf("%d",&n)!=EOF)
	{
		memset(dist,INF,sizeof(dist));
		for(i=0;i<n;++i)
		{
			scanf("%d%d",&m,&p[i]);
			
			while(m--)
			{
				scanf("%d%d",&v,&w);
				dist[i][v]=dist[v][i]=w;
			}
		}
		Floyd();
		int Min=INF;
		for(i=0;i<n;++i)
		{
			if(p[i]==1 && Min>dist[0][i])
				Min=dist[0][i];
		}
		printf("%d\n",Min);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值