1151 LCA in a Binary Tree (30 分)

37 篇文章 0 订阅
该博客介绍了如何通过中序和前序遍历序列在不构建二叉树的情况下找到二叉树中两个节点的最近公共祖先(LCA)。给出的算法根据节点在遍历序列中的位置来确定LCA,避免了实际建树的过程,提高了效率。对于不在树中的节点或未找到的情况,程序会输出相应的错误信息。
摘要由CSDN通过智能技术生成

1151 LCA in a Binary Tree (30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

不需要建树,已知某个树的根节点,若a和b在根节点的左边,则a和b的最近公共祖先在当前子树根节点的左子树寻找,如果a和b在当前子树根节点的两边,则当前子树的根节点就是a和b的最近公共祖先。如果a和b在根节点的右边,则a和b的最近公共祖先在当前子树根节点的右子树寻找,再加上当前字数节点刚刚好就是a或者b的情况。

#include<bits/stdc++.h>
using namespace std;

unordered_map<int, int> pos;
vector<int> in, pre;
void LCA(int inL, int inR, int preRoot, int a, int b) {
	if (inL > inR) return;
	int inRoot = pos[pre[preRoot]];
	if (pos[a] < inRoot && pos[b] < inRoot) {
		LCA(inL, inRoot - 1, preRoot + 1, a, b);
	} else if ((pos[a] < inRoot && pos[b] > inRoot) || (pos[a] > inRoot && pos[b] < inRoot)) {
		printf("LCA of %d and %d is %d.\n", a, b, in[inRoot]);
	} else if (pos[a] > inRoot && pos[b] > inRoot) {
		LCA(inRoot + 1, inR, preRoot + 1 + (inRoot - inL), a, b);
	} else if (pos[a] == inRoot) {
		printf("%d is an ancestor of %d.\n", a, b);
	} else if (pos[b] == inRoot) {
		printf("%d is an ancestor of %d.\n", b, a);
	}
	
}
int main() {
	int m, n, a, b;
	scanf("%d %d", &m, &n);
	in.resize(n + 1);
	pre.resize(n + 1);
	for (int i = 1; i <= n; i++) {
		scanf("%d", &in[i]);
		pos[in[i]] = i;
	}
	for (int i = 1; i <= n; i++) scanf("%d", &pre[i]);
	for (int i = 0; i < m; i++) {
		scanf("%d %d", &a, &b);
		if (pos[a] == 0 && pos[b] == 0) {
			printf("ERROR: %d and %d are not found.\n", a, b);
		} else if (pos[a] == 0 || pos[b] == 0) {
			printf("ERROR: %d is not found.\n", pos[a] == 0 ? a : b);
		} else {
			LCA(1, n, 1, a, b);
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值