PAT(甲级)2020年冬季考试7-3 File Path (25分)

7-3File Path(25分)

在这里插入图片描述
The figure shows the tree view of directories in Windows File Explorer. When a file is selected, there is a file path shown in the above navigation bar. Now given a tree view of directories, your job is to print the file path for any selected file.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​3​​ ), which is the total number of directories and files. Then N lines follow, each gives the unique 4-digit ID of a file or a directory, starting from the unique root ID 0000. The format is that the files of depth d will have their IDs indented by d spaces. It is guaranteed that there is no conflict in this tree structure.

Then a positive integer K (≤100) is given, followed by K queries of IDs.

Output Specification:

For each queried ID, print in a line the corresponding path from the root to the file in the format: 0000->ID1->ID2->…->ID. If the ID is not in the tree, print Error: ID is not found. instead.

Sample Input:

14
0000
1234
2234
3234
4234
4235
2333
5234
6234
7234
9999
0001
8234
0002
4 9999 8234 0002 6666

Sample Output:

0000->1234->2234->6234->7234->9999
0000->1234->0001->8234
0000->0002
Error: 6666 is not found.

有点并查集的感觉

#include<bits/stdc++.h>
using namespace std; 
int N, father[10005], v[1005], K, data;
unordered_map<int, int> m;
int main() {
	scanf("%d", &N);
	for (int i = 0; i < 10005; i++) {
		father[i] = i;
	}
	string s;
	getchar();
	for (int i = 0; i < N; i++) {
		getline(cin, s);
		int cnt = 0;
		for (int j = 0; j < s.size(); j++) {
			if (s[j] == ' ') cnt++;
			else break;
		}
		m[stoi(s)] = cnt;
		v[i] = stoi(s);
	}
	for (int i = 1; i < N; i++) {
		if (m[v[i]] == m[v[i - 1]] + 1) {
			father[v[i]] = v[i - 1]; 
		} else if (m[v[i]] == m[v[i - 1]]) {
			father[v[i]] = father[v[i - 1]]; 
		} else if (m[v[i]] < m[v[i - 1]]) {
			int temp = v[i - 1];
			while (m[v[i]] != m[temp]) {
				temp = father[temp];
			}
			father[v[i]] = father[temp];
		}
	}
	scanf("%d", &K);
	for (int i = 0; i < K; i++) {
		scanf("%d", &data);
		if (data != 0 && father[data] == data) {
			printf("Error: %04d is not found.\n", data);
			continue;
		}
		stack<int> st;
		while (father[data] != data) {
			st.push(data);
			data = father[data];
		}
		st.push(data);
		while (!st.empty()) {
			int temp = st.top();
			st.pop();
			printf("%04d", temp);
			if (!st.empty()) {
				printf("->");
			}
		}
		printf("\n");
	}
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值