1127 ZigZagging on a Tree (30 分)

37 篇文章 0 订阅

1127 ZigZagging on a Tree (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

==根据中序遍历和后序遍历建树,tree[index][0]存放的是后序遍历中索引为index的节点的左子节点在后序遍历中的索引,ree[index][1]存放的是后序遍历中索引为index的节点的右子节点在后序遍历中的索引,然后通过bfs将每一层的节点数据存到对应的result[i]中,i从0开始,偶数层从右往左遍历,寄数层从左往右遍历 ==

#include<bits/stdc++.h>
using namespace std;
struct node{
	int index, level;
};
int tree[35][2];
unordered_map<int, int> m;
vector<int> in, post, result[35];
void dfs(int &index, int inL, int inR, int postRoot) {
	if (inL > inR) return ;
	int inRoot = m[post[postRoot]];
	index = postRoot;
	dfs(tree[index][0], inL, inRoot - 1, postRoot - (inR - inRoot + 1));
	dfs(tree[index][1], inRoot + 1, inR, postRoot - 1);
}
void bfs(int root) {
	queue<node> q;
	q.push(node{root, 0});
	while (!q.empty()) {
		node temp = q.front();
		q.pop();
		result[temp.level].push_back(post[temp.index]);
		if (tree[temp.index][0] != 0) q.push(node{tree[temp.index][0], temp.level + 1});
		if (tree[temp.index][1] != 0) q.push(node{tree[temp.index][1], temp.level + 1});
	}
	printf("%d", result[0][0]);
	for (int i = 1; i < 35 && result[i].size() > 0; i++) {
		if (i % 2 == 0) {
			for (int j = result[i].size() - 1; j >= 0; j--) {
				printf(" %d", result[i][j]);
			}
		} else {
			for (int j = 0; j < result[i].size(); j++) {
				printf(" %d", result[i][j]);
			}
		}
	}
}
int main() {
	int n, root;
	scanf("%d", &n);
	in.resize(n + 1);
	post.resize(n + 1);
	for (int i = 1; i <= n; i++) {
		scanf("%d", &in[i]);
		m[in[i]] = i;
	}
	for (int i = 1; i <= n; i++) {
		scanf("%d", &post[i]);
	}
	dfs(root, 1, n, n);
	bfs(root);
	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
信息数据从传统到当代,是一直在变革当中,突如其来的互联网让传统的信息管理看到了革命性的曙光,因为传统信息管理从时效性,还是安全性,还是可操作性等各个方面来讲,遇到了互联网时代才发现能补上自古以来的短板,有效的提升管理的效率和业务水平。传统的管理模式,时间越久管理的内容越多,也需要更多的人来对数据进行整理,并且数据的汇总查询方面效率也是极其的低下,并且数据安全方面永远不会保证安全性能。结合数据内容管理的种种缺点,在互联网时代都可以得到有效的补充。结合先进的互联网技术,开发符合需求的软件,让数据内容管理不管是从录入的及时性,查看的及时性还是汇总析的及时性,都能让正确率达到最高,管理更加的科学和便捷。本次开发的医院后台管理系统实现了病房管理、病例管理、处方管理、字典管理、公告信息管理、患者管理、药品管理、医生管理、预约医生管理、住院管理、管理员管理等功能。系统用到了关系型数据库中王者MySql作为系统的数据库,有效的对数据进行安全的存储,有效的备份,对数据可靠性方面得到了保证。并且程序也具备程序需求的所有功能,使得操作性还是安全性都大大提高,让医院后台管理系统更能从理念走到现实,确确实实的让人们提升信息处理效率。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值