UVa 188 - Perfect Hash

题目链接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=124


类型: 哈希


原题:

Perfect Software, Inc. has obtained a government contract to examine text flowing through a high-speed network for the occurrence of certain words. Your boss, Wally Perfect, has designed a parallel processing system which checks each word against a group of small perfect hash tables.

A perfect hash function maps its input directly to a fully occupied table. Your job is to construct the perfect hash functions from the lists of words in each table. The hash function is of the formtex2html_wrap_inline63 , where C is a positive integer you are to discover, w is an integer representation of an input word, and n is the length of the table. C must be as small as possible. Note that tex2html_wrap_inline73 is the floor function and that tex2html_wrap_inline75 for some real number R is the largest integer that is tex2html_wrap_inline79 .

Here are Wally's notes on the subject:

Let tex2html_wrap_inline81 consist of positive integers tex2html_wrap_inline83 . The problem is to find the smallest positive integer C such that

tex2html_wrap_inline87 for all tex2html_wrap_inline89 .

C must be a multiple of at least one element of W.

If some

tex2html_wrap_inline95 for all tex2html_wrap_inline97 ,

then the next largest C that could resolve the conflict is at least

displaymath61

Since all such conflicts must be resolved, it is advantageous to choose the largest candidate from among the conflicts as the next C to test.

You are to convert each word to a number by processing each letter from left to right. Consider `a' to be 1, `b' to be 2, tex2html_wrap_inline103 , `z' to be 26. Use 5 bits for each letter (shift left by 5 or multiply by 32). Thus `a' = 1, `bz' = tex2html_wrap_inline105 .

Input

Input to your program will be a series of word lists, one per line, terminated by the end-of-file. Each line consists of between two and thirteen words of at most five lower case letters each, separated from each other by at least one blank. There will always be at least one one-letter word.

For each list, you are to print the input line. On the next line, print the C for the hash function determined by the list. Print a blank line after each C.

C will always fit in a 32-bit integer.

Sample input

this is a test of some words to try out
a bee see dee
the of and to a in that is i it with for as

Sample output

this is a test of some words to try out
17247663

a bee see dee
4427

the of and to a in that is i it with for as
667241


题目大意 + 分析与总结:


真心不喜欢这种题目, 题意很难弄懂,而弄懂了之后就像切菜一样地切。


有一个完美哈希函数,其中tex2html_wrap_inline63,C是一个正数, 也就是你要找的那个数(结果要输出这个数)。w是由一个单词转换得到的数字,例如 `a' = 1, `bz' = tex2html_wrap_inline105, 可以把它看成是32进制的转换。 n其实就是代表的是一行中的单词的个数。

然后怎样求出C呢?

首先对于tex2html_wrap_inline81 tex2html_wrap_inline83 .是由一行中的各个单词转换而来的,然后题目说C must be a multiple of at least one element of W.  也就是C必须是W中某一个的倍数, 然后再上面点还说C must be as small as possible.   C必须尽可能地小。 所以,在开始时, 让C等于w1(w1是最小的,因为W集合已经排好序了:tex2html_wrap_inline83)。 

对于C,要让它符合条件tex2html_wrap_inline87 for all tex2html_wrap_inline89 . 所以要用一个两层for循环来判断。

如果不符合的话,就让C等于:

displaymath61

一直到找到符合的条件C为止,答案就出来了。



代码:

#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<algorithm>
using namespace std;  
int n, W[15], C, ans;  
  
inline int min(int a, int b){  
    return a<b?a:b;  
}  
// 递归找出符合条件的C  
void solve( ){  
    for(int i=0; i<n; ++i){  
        for(int j=i+1; j<n; ++j)if((C/W[i])%n==(C/W[j])%n){  
            C = min((C/W[i]+1)*W[i], (C/W[j]+1)*W[j]);   
            solve();  
            return ;  
        }  
    }     
}  
  
int main(){   
    char str[200];  
    int i;  
    while(gets(str)){  
        n=0;    memset(W, 0, sizeof(W));  
        for(i=0; i<=strlen(str); ++i){  
            if(str[i]==' ' || str[i]=='\0'){              
                ++n;  
                while(str[i+1]==' ')++i;  // 跳过连续的空格
            }  
            else{  
                W[n] = (W[n]<<5)+str[i]-'a'+1;  
            }  
        }  
        sort(W, W+n); // 排序,让w1<w2<w3...<wn
        C = W[0];
        solve();   
        puts(str);  
        printf("%d\n", C);  
        puts("");  
    }  
    return 0;  
}  

 
 

——  生命的意义,在于赋予它意义。

 

          
     原创  http://blog.csdn.net/shuangde800  , By   D_Double  (转载请标明)

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值