UVa 10020 - Minimal coverage

链接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=961


类型: 贪心


原题:

The Problem

Given several segments of line (int the X axis) with coordinates [Li,Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0,M].

The Input

The first line is the number of test cases, followed by a blank line.

Each test case in the input should contains an integer M(1<=M<=5000), followed by pairs "Li Ri"(|Li|, |Ri|<=50000, i<=100000), each on a separate line. Each test case of input is terminated by pair "0 0".

Each test case will be separated by a single line.

The Output

For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0,M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair "0 0" should not be printed. If [0,M] can not be covered by given line segments, your programm should print "0"(without quotes).

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

1
-1 0
-5 -3
2 5
0 0

1
-1 0
0 1
0 0

Sample Output

0

1
0 1

分析与总结:

贪心的经典区间最小覆盖问题。LRJ《算法入门经典》P154。 

对于区间【left, right】, 按照left从小到大排序,设起点为s, 那么选择left<=s中的right最大的那个为新的起点s, 如此循环下去,一直到起点s大于目标长度为止。


/* 
 *   UVa: 10020 - Minimal coverage
 *   Result: Accept
 *   Time: 0.080s
 *   Author: D_Double                                                                 
 */
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#define MAXN 100005
using namespace std;
int M;

struct Segment{
	int left;
	int right;
	friend bool operator < (const Segment&a, const Segment&b){
		if(a.left!=b.left) return a.left<b.left;
		return a.right>b.left;
	}
}arr[MAXN];
int nIndex;

int ans[MAXN], N;

int main(){
	freopen("input.txt","r",stdin);
	int T, i;
	scanf("%d",&T);
	while(T--){
		nIndex=0;
		scanf("%d",&M);
		while(~scanf("%d %d",&arr[nIndex].left, &arr[nIndex].right)){
			if(!arr[nIndex].left && !arr[nIndex].right) break;
			if(arr[nIndex].right>0) ++nIndex;
		}

		sort(arr, arr+nIndex);
		int cur = 0;
		N=-1;

		bool flag=false;

		if(arr[0].left > 0){
			printf("0\n");
			if(T) printf("\n");
			continue;
		}

		for(i=0; i<nIndex; ++i){
			if(arr[i].left <= cur){
				if(N==-1) 
					ans[++N]=i;
				else if(arr[i].right > arr[ans[N]].right)
					ans[N]=i;
			}
			else{
				cur=arr[ans[N]].right;
				ans[++N]=i;
			}
			if(arr[ans[N]].right>=M){
				flag=true; 
				break;
			}
		}
 
		if(flag){
			printf("%d\n", N+1);
			for(i=0; i<=N; ++i)
				printf("%d %d\n", arr[ans[i]].left, arr[ans[i]].right);
		}
		else
			printf("0\n");
		if(T) printf("\n");
	}
	return 0;
}

——  生命的意义,在于赋予它意义。

          
     原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值