Prime Path(C语言)

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input

3
1033 8179
1373 8017
1033 1033
Sample Output

6
7
0

解题思路:BFS广搜,改变个位,十位,百位,千位进行搜索,若为素数则入队(判断素数可采用打表的方法)

代码如下

#include<stdio.h>
#include<string.h>

void prime();                   //素数打表

int judge[10000] = {1,1};

int num[10000];                 //剪枝

int BFS(int begin,int end);     //广搜

struct Q
{
    int x;
    int count;
}queue[10000];                  //用结构体模仿队列

int main()
{
    int t,ans;
    int x,y;
    scanf("%d",&t);
    prime();
    while(t--)
    {
        memset(num,0,sizeof(num));  //注意每次的归0
        scanf("%d%d",&x,&y);
        if(x == y)
        {
            printf("0\n");
            continue;
        }
        ans = BFS(x,y);
        if(ans == -1)  printf("Impossible\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}

void prime()                    //素数打表
{
    int i,j;
    for(i = 2 ; i*i <= 10000 ; i++)
    {
        if(!judge[i])
        {
            for(j = i*i ; j <= 10000 ; j += i)
            {
                judge[j] = 1;
            }
        }

    }
}

int BFS(int begin,int end)      //广搜
{
    struct Q temp;
    int j;
    int head = 0 , rear = 0;    //head表示队首,rear表示队尾
    queue[rear].x = begin;
    queue[rear++].count = 0;
    num[begin] = 1;             //标记该数已出现
    while(head < rear)          //队列不为空
    {
        temp = queue[head++];
        for(j = 0 ; j <= 9 ; j++)
        {
            if(!judge[temp.x/10*10+j] && !num[temp.x/10*10+j])    //个位
            {
                queue[rear].x = temp.x/10*10+j;
                queue[rear++].count = temp.count+1;
                num[temp.x/10*10+j] = 1;
                if(temp.x/10*10+j == end)
                    return temp.count+1;
            }
            if(!judge[temp.x%10+(temp.x/100*10+j)*10] && !num[temp.x%10+(temp.x/100*10+j)*10])       //十位
            {
                queue[rear].x = temp.x%10+(temp.x/100*10+j)*10;
                queue[rear++].count = temp.count+1;
                num[temp.x%10+(temp.x/100*10+j)*10] = 1;
                if(temp.x%10+(temp.x/100*10+j)*10 == end)
                    return temp.count+1;
            }
            if(!judge[temp.x%100+(temp.x/1000*10+j)*100] && !num[temp.x%100+(temp.x/1000*10+j)*100]) //百位
            {
                queue[rear].x = temp.x%100+(temp.x/1000*10+j)*100;
                queue[rear++].count = temp.count+1;
                num[temp.x%100+(temp.x/1000*10+j)*100] = 1;
                if(temp.x%100+(temp.x/1000*10+j)*100 == end)
                    return temp.count+1;
            }
            if(j!=0 && !judge[temp.x%1000+(temp.x/10000*10+j)*1000] && !num[temp.x%1000+(temp.x/10000*10+j)*1000])    //千位,注意此时最高位不能为0
            {
                queue[rear].x = temp.x%1000+(temp.x/10000*10+j)*1000;
                queue[rear++].count = temp.count+1;
                num[temp.x%1000+(temp.x/10000*10+j)*1000] = 1;
                if(temp.x%1000+(temp.x/10000*10+j)*1000 == end)
                    return temp.count+1;
            }
        }
    }
    return -1;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值