三分法

二分法:单调增或单调减

三分法:适用于凸函数

mid=(l+r)/2;

mmid=(mid+r)/2;

//

Light Bulb

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

 

Input

 

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

 

Output

 

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

 

Sample Input

 

 

3
2 1 0.5
2 0.5 3
4 3 4

 

 

Sample Output

 

 

1.000
0.750
4.000

题解:

计算出来的这条式子,可以直接进行三分,求出极值点,但是同样,我们可以通过这条公式用O(1)的方法求出来

注:浮点数不能直接比较大小

需要定义精度 一般小于10^{-7}或者10^{-9}

#define eps 1e-8

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#define eps 1e-8
using namespace std;
double  H,h,D;
double ans(double y)
{
    double x;
    x=D-y+H-(H-h)*D/y;
    return x;
}
double s(double l,double r)
{
   double mid,mmid,left,right;
   left=l;
     right=r;
     while(left+eps<right)
     {
     mid=(left+right)/2;
     mmid=(mid+right)/2;
         if(ans(mid)>=ans(mmid))
            right=mmid;
         else
            left=mid;
     }
    return ans(right);
}
int main()
{

    int t;

    scanf("%d",&t);
    while(t--)
    {
     scanf("%lf %lf %lf",&H,&h,&D);
     double l=D-D*h/H,r=D;
     double f=s(l,r);
     printf("%.3f\n",f);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值