POJ1979(DFS)

POJ1979(DFS)


Red and Black

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
题意

有一个矩形的房间,里面铺满了方形的瓷砖。每一个瓷砖有红色还有黑色两种,人只能站在黑色的瓷砖上不能站在红色的瓷砖上,每次只能走前后左右四个方向的四个瓷砖,计算能够到达的黑色瓷砖的总面积数。

思路

进行一个简单的dfs,从起始点向四个方向分别进行dfs。

代码
import java.util.Scanner;

public class RedAndBlack {

    int[][] map = new int[25][25];
    int startx;
    int starty;
    int[] xs = {-1, 0, 0, 1};
    int[] ys = {0, -1, 1, 0};
    int count = 0;

    public void dfs(int x, int y) {
        this.count = this.count + 1;
        if (this.map[x][y] == 1) {
            this.map[x][y] = 0;
        }
        for (int i = 0; i < 4; i++) {
            if (this.map[x + xs[i]][y + ys[i]] == 1) {
                dfs(x + xs[i], y + ys[i]);
            }
        }
    }

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while (true) {
            int m = sc.nextInt();
            int n = sc.nextInt();
            if (m == 0 && n == 0) {
                break;
            }
            RedAndBlack rb = new RedAndBlack();

            for (int i = 1; i <= n; i++) {
                String str = sc.next();
                for (int j = 1; j <= m; j++) {
                    if (str.charAt(j - 1) == '.') {
                        rb.map[i][j] = 1;
                    }
                    if (str.charAt(j - 1) == '@') {
                        rb.startx = i;
                        rb.starty = j;
                    }
                }
            }
            rb.dfs(rb.startx, rb.starty);
            System.out.println(rb.count);
        }
        sc.close();
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值