POJ1250

POJ1250(链表)


Tanning Salon

Description

Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave, thus costing the company a sale. Your task is to write a program that tells the company how many customers left without tanning.

Input

The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning beds in the salon, followed by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will occur in more than one pair. Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon.

Output

For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below.

Sample Input

2 ABBAJJKZKZ
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0

Sample Output

All customers tanned successfully.
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.
题意

​ 旅馆床位有限,按顺序入住,用ABC等代表单个人,第1次出现代表入住,第2次出现代表离开。求有多少位顾客未住店就离开了。

思路

​ 用两个集合模拟链表。一个记录房间的状态,一个记录未住店离开的顾客。

代码
public class TanningSalon {
  public static void main(String[] args) {
    Scanner sc = new Scanner(System.in);
    while (true) {
      int n = sc.nextInt();
      if (n == 0) {
        break;
      }
      int result = 0;
      String str = sc.next();
      List<Character> room = new ArrayList<Character>();
      List<Character> person = new ArrayList<Character>();
      for (int i = 0; i < str.length(); i++) {
        char c = str.charAt(i);
        if (room.contains(c)) {//是否以及入住
          room.remove((Character) c);
        } else {
          if (room.size() < n) {//是否还有空房间
            room.add(c);
          } else {
            if (!person.contains(c)) {
              result++;
              person.add(c);
            }

          }
        }
      }
      if (result == 0) {
        System.out.println("All customers tanned successfully.");
      } else {
        System.out.println(result + " customer(s) walked away.");
      }
    }
  }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值