一、G - 请使用sort

G - 请使用sort

HDU - 1225

Football is one of the greatest games in the world. Lots of people like to play football. After one season of matches, the header has to calculate the last scores of every team. He is too lazy that he doesn't want to calculate, so he asks you to write a program for him to solve the problem.

Here are the rules:
1 Every team has to match with all the other teams.
2 Every two teams have to match for two times,one at home and one away.
3 In one match, the winner will get 3 points, the loser will get 0 point. If it is draw, both of them will get 1 point.

Input

The input consists of many test cases. In each case, there will be a number N in the first line which means the number of teams. Followed by N * (N – 1)lines. Each line stands for a match between two teams. The format is: "Team1 VS Team2 p:q", p stands for the balls that Team1 has kicked in and q stands for the balls that Team2 has kicked in. p and q are not greater than 9.

Process to the end of file.

Output

For each test case, output the teams and their scores in descending order. One line a team, the format is: "TeamX scores". If two teams get the same score, the one with high net goals will be ahead, which net goal means the difference between the total balls that the team kicked in and the total balls that the team lost. IE: if one team kicked in 30 balls and lost 40 balls, then the net goal is 30 – 40 = -10. If two teams have the same score and the same net goal, the one whose kicked in balls is bigger will be ahead. If two teams have the same score and the same net goal and the same kicked in balls, they will be outputed in alphabetic order.

Output a blank line after each test case.

Sample Input

3
Manchester VS Portsmouth 3:0
Liverpool VS Manchester 1:1
Liverpool VS Portsmouth 0:0
Portsmouth VS Manchester 1:1
Manchester VS Liverpool 2:1
Liverpool VS Portsmouth 1:2

Sample Output

Manchester 8
Portsmouth 5
Liverpool 2


        
  
Huge input, scanf is recommended.

计算每个球队的得分,净胜球数和进球数,然后按照所给顺序排序,之后直接输出即可。

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <map>
#include <string.h>
#include <string>

using namespace std;

struct group
{
    string name;
    int score,num,goal;
};

bool cmp(group x,group y)
{
    if(x.score!=y.score)
    {
        return x.score>y.score;
    }
    if(x.num!=y.num)
    {
        return x.num>y.num;
    }
    if(x.goal!=y.goal)
    {
        return x.goal>y.goal;
    }
    return x.name<y.name;
}

int main()
{

    int i,n,n1,score1,score2;
    group g[1000];
    char group1[30],group2[30];
    while(scanf("%d",&n)!=EOF)
    {
        map<string,int>name;
        for(i=1;i<=n;i++)
        {
            g[i].score=0;
            g[i].num=0;
            g[i].goal=0;
        }
        n1=1;
        for(i=0;i<n*(n-1);i++)
        {
            scanf("%s VS %s %d:%d",group1,group2,&score1,&score2);
            if(name[group1]==0)
            {
                name[group1]=n1;
                g[n1].name=group1;
                n1++;
            }
            if(name[group2]==0)
            {
                name[group2]=n1;
                g[n1].name=group2;
                n1++;
            }
            g[name[group1]].num+=score1-score2;
            g[name[group2]].num+=score2-score1;
            g[name[group1]].goal+=score1;
            g[name[group2]].goal+=score2;
            if(score1>score2) g[name[group1]].score+=3;
            else if(score1<score2) g[name[group2]].score+=3;
            else
            {
                g[name[group1]].score+=1;
                g[name[group2]].score+=1;
            }
        }
        sort(g+1,g+n+1,cmp);
        for(i=1;i<=n;i++)
        {
            cout<<g[i].name<<" "<<g[i].score<<endl;
        }
        cout<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值