一、R - Joseph

R - Joseph

POJ - 1012

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
 

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5
30

题意:约瑟夫问题是众所周知的。对于那些并不熟悉原来问题的人,在这里重述一下问题:对于一共n个人,编号1,2,…,n,站成一圈,每第m个人离开,然后剩下的最后一个人将幸存。约瑟夫比较聪明,知道哪个位子不用死,因而能够活下来把事件的讯息传达给我们。比如当n=6时m=5人将按照5,4,6,2,3一次离开,然后1将存活。假设那里有k个好人和k个坏人。在一圈中,前k个是好人后k个是坏人。你必须设计一个最小的m可以让坏人先于好人离开。

约瑟夫环公式:从编号0—n-1个人:

arr[i]=(arr[i-1]+m)%n;//从0开始报数

arr[i]=(arr[i-1]+m)%(n-1);//从1开始报数

思路:从m=1开始模拟报数过程,如果离开的是好人,则m++,直到找到合适的m。

#include <stdio.h>
#include <stdlib.h>
#include <memory.h>
int main()
{

    int k,i,n,m,ans[15],locat[15];
    locat[0]=0;
    memset(ans,0,sizeof(ans));
    while(scanf("%d",&k)&&k)
    {
        if(ans[k]==0)
        {
            n=2*k;
            m=1;
            for(i=1;i<=k;i++)
            {
                locat[i]=(locat[i-1]+m-1)%(n-i+1);
                if(locat[i]<k)
                {
                    m++;
                    i=0;
                }
            }
            ans[k]=m;
        }
        printf("%d\n",ans[k]);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值