一、U - Long Distance Racing

U - Long Distance Racing

POJ - 3672

Bessie is training for her next race by running on a path that includes hills so that she will be prepared for any terrain. She has planned a straight path and wants to run as far as she can -- but she must be back to the farm within M seconds (1 ≤ M ≤ 10,000,000).

The entire path she has chosen is T units (1 ≤ T ≤ 100,000) in length and consists of equal-length portions that are uphill, flat, or downhill. The input data describes path segment i with a single character Si that is u, f, or d, indicating respectively uphill, flat, or downhill.

Bessie takes U seconds (1 ≤ U ≤ 100) to run one unit of uphill path, F (1 ≤ F ≤ 100) seconds for a unit of flat path, and D (1 ≤ D ≤ 100) seconds for a unit of downhill path. Note that, when returning home, uphill paths become downhill paths and downhill paths become uphill paths.

Find the farthest distance Bessie can get from the farm and still make it back in time.

Input

* Line 1: Five space-separated integers: M, T, U, F, and D
* Lines 2..T+1: Line i+1 describes path segment i with a single letter: Si

Output

* Line 1: A single integer that is the farthest distance (number of units) that Bessie can get from the farm and make it back in time.

Sample Input

13 5 3 2 1
u
f
u
d
f

Sample Output

3

 

题意:平路、上坡、下坡所花费的时间是不同的,现在给出时间M,路的段数T,上坡、平路、下坡所花费时间U F D,路程是往返的,问在时间T内最多走多远。

思路:水题。去的时候上坡返回的时候就变为下坡,同理,去的时候下坡返回的时候变为上坡,即无论是上坡还是下坡往返所需时间为:U+D。平路往返所需时间2*F。

#include <stdio.h>
#include <stdlib.h>

int main()
{
    int M,T,U,F,D;
    while(scanf("%d %d %d %d %d",&M,&T,&U,&F,&D)!=EOF)
    {
        int i,t=0,l=0;
        char temp;
        for(i=0;i<T;i++)
        {
            getchar();
            scanf("%c",&temp);
            if(temp=='u'||temp=='d') t=t+U+D;
            else if(temp=='f') t+=2*F;

            if(t<M) l++;
            else continue;
        }
        printf("%d\n",l);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值