HDOJ 1002 A + B Problem II ( 大数相加)

A + B Problem II(点击进入题目)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 314071    Accepted Submission(s): 60860


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1004  1005  1009  1020  1010 
 

模拟大数运算后注意输出的格式(英语好就不会是问题,我就是问题)。

代码:

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#define MYDD 1103

using namespace std;

int main() {
	int long_A,long_B,T;
	int sum[MYDD],a[MYDD],b[MYDD];
	char A[MYDD],B[MYDD];
	scanf("%d",&T);
	for(int t=1; t<=T; t++) {

		memset(sum,0,sizeof(sum));
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		scanf("%s %s",A,B);

		long_A=strlen(A);
		long_B=strlen(B);
		int max_l=max(long_A,long_B);
		for(int j=long_A-1,i=0; j>=0; j--)
			a[i++]=A[j]-'0';
		for(int j=long_B-1,i=0; j>=0; j--)
			b[i++]=B[j]-'0';

		for(int j=0; j<max_l; j++) {
			sum[j]=a[j]+b[j]+sum[j];//包证前一位进位的数字要加上
			if(sum[j]>9) {
				sum[j+1]++;
				sum[j]-=10;
			}
		}
		printf("Case %d:\n",t);

		for(int j=long_A-1; j>=0; j--)
			printf("%d",a[j]);

		printf(" + ");

		for(int j=long_B-1; j>=0; j--)
			printf("%d",b[j]);

		printf(" = ");

		if(sum[max_l]!=0)//首位是否为 0
			printf("%d",sum[max_l]);
		for(int i=max_l-1; i>=0; i--)
			printf("%d", sum[i]);
		printf("\n");//保证格式正确 
		if(t!=T)
			printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值