HDU 5631 Rikka with Graph / UVALive - 7240 Minimum Cut-Cut(删边操作,BestCoder)

Rikka with Graph(进入答题)



Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1031    Accepted Submission(s): 491


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number T(T30) ——The number of the testcases.

For each testcase, the first line contains a number n(n100) .

Then n+1 lines follow. Each line contains two numbers u,v , which means there is an edge between u and v.
 

Output
For each testcase, print a single number.
 

Sample Input
  
  
1 3 1 2 2 3 3 1 1 3
 

Sample Output
  
  
9
 

Source


题意:

就是给定一个图,删除一条边或者两条边之后,仍然能够保持连通的操作有多少种。


思路:

第一次接触删边操作,自然参考了题解,但愿自己的注释没写错。


AC代码:

#include<stdio.h>
#define MYDD 1103

int n,pre[MYDD];//记录父节点
struct node { //记录边信息的结构体
	int u;//起点
	int v;//终点
	int flag;//标记是否已经使用
} dd[MYDD];

void init(int x) {
	for(int j=1; j<=x; j++)
		pre[j]=j;
}

int find(int x) {
	return x==pre[x]? x:find(pre[x]);
}

void combine(int x,int y) {
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
		pre[fx]=fy;
}

bool Delete() { //删除边的操作
	init(n);
	for(int j=0; j<=n; j++) {
		if(dd[j].flag)
			combine(dd[j].u,dd[j].v);
	}

	int sum=0;//统计树的个数,即是否连通
	for(int j=1; j<=n; j++) {
		if(pre[j]==j)//根节点等于本身就是一棵树
			sum++;
		if(sum>1) {//存在大于 1 个的树 
			return false;//不成立 
		}
	}
	return true;//成立 
}

int main() {
	int t;
	scanf("%d",&t);
	while(t--) {
		scanf("%d",&n);
		for(int j=0; j<=n; j++) {
			scanf("%d%d",&dd[j].u,&dd[j].v);
			dd[j].flag=1;
		}

		int ans=0;//记录删除边之后满足的答案 
		for(int j=0; j<=n; j++) {
			dd[j].flag=0;
			if(Delete())//删除一条边
				ans++;
			for(int k=j+1; k<=n; k++) {
				dd[k].flag=0;
				if(Delete())//删除两条边的操作
					ans++;
				dd[k].flag=1;//边的还原
			}
			dd[j].flag=1;//边的还原,为了下一次删边保证原图完整 
		}

		printf("%d\n",ans);
	}
	return 0;
}



************************************************



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值