HDU 2120 Ice_cream's world I(并查集,环的个数,冰激凌王国有什么?)

10 篇文章 0 订阅

Ice_cream's world I(题目)

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1254    Accepted Submission(s): 750


Problem Description
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 

Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
 

Sample Input
  
  
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 

Sample Output
  
  
3
 

Author
Wiskey
 

Source
 



题意:

这翻译也是够了,大意就是女王分土地的问题吧。(有道翻译的没明白)直接过思路吧。


思路:

想到判断有几个环在图中,这个题目就迎刃而解了。


代码:

#include<stdio.h>
#define MYDD 10000

int pre[MYDD];
void init(int x) {
	for(int j=0; j<x; j++)
		pre[j]=j;
}

int find(int x) {//根节点查找函数 
	return x==pre[x]? x:find(pre[x]);
}

bool combine(int x,int y) {//判断是否成环
	int fx=find(x);
	int fy=find(y);
	if(fx==fy)//根节点相同,成环
		return true;
	else {
		pre[fx]=fy;
		return false;
	}
}

int main() {
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF) {
		init(n);//初始化 
		int ans=0;
		while(m--) {
			int a,b;
			scanf("%d%d",&a,&b);
			if(combine(a,b))//成环 
				ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}


后:

别人一分钟学会的,你花十分钟掌握也行,不怕走得慢,就怕怠慢。

***********************************************************************************


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值