POJ 2585 Window Pains(窗口的颜色显示问题,拓扑排序,经典题目)

7 篇文章 0 订阅
7 篇文章 0 订阅

Window Pains(点击>>原POJ)
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1980 Accepted: 998

Description

Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux's windows would be represented by the following 2 x 2 windows: 
11..
11..
....
....
.22.
.22.
....
....
..33
..33
....
....
....
44..
44..
....
....
.55.
.55.
....
....
..66
..66
....
....
....
77..
77..
....
....
.88.
.88.
....
....
..99
..99
When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window  1 and then window  2 were brought to the foreground, the resulting representation would be:
122?
122?
????
????
If window 4 were then brought to the foreground:
122?
442?
44??
????
. . . and so on . . . 
Unfortunately, Boudreaux's computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . .

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 

A single data set has 3 components: 
  1. Start line - A single line: 
    START 

  2. Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux's screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space. 
  3. End line - A single line: 
    END 

After the last data set, there will be a single line: 
ENDOFINPUT 

Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.

Output

For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux's screen, the output will be a single line with the statement: 

THESE WINDOWS ARE CLEAN 

Otherwise, the output will be a single line with the statement: 
THESE WINDOWS ARE BROKEN 

Sample Input

START
1 2 3 3
4 5 6 6
7 8 9 9
7 8 9 9
END
START
1 1 3 3
4 1 3 3
7 7 9 9
7 7 9 9
END
ENDOFINPUT

Sample Output

THESE WINDOWS ARE CLEAN
THESE WINDOWS ARE BROKEN

Source



i题意:

显示颜色的问题,一种颜色有一种显示的区域,大的可以覆盖小的。给定几个矩阵,问显示效果怎么样,好的话输出一句,否则输出另外一句。

具体参考书籍《图论》哈工大出版社。


i思路:

每个显色的数字位置如图:

这可是学姐在黑板上一点点画出来的图(这是我用EXCEL打的),讲题挺认真的,负责。



i参考代码:

实现方式:二维数组

#include<stdio.h>
#include<string.h>
const int MYDD=1103;

int indegree[MYDD];
int map[113][113];
int dx[]= {0,1,0,1};
int dy[]= {0,0,1,1}; //移动的方向,注意不同于搜索
int local[10][2]= {-1,-1, 0,0, 0,1, 0,2, 1,0, 1,1, 1,2, 2,0, 2,1, 2,2};
//窗口的固定位置
bool TopoSort() {
	int now,flag;// now 当前选中的节点;flag 标记合法性
	for(int j=1; j<=9; j++) {
		flag=0;
		for(int i=1; i<=9; i++) {
			if(!indegree[i]) {
				flag=1;
				now=i;
				break;//入度为 0 即前驱
			}
		}
		if(!flag)   return false;
		indegree[now]=-1;//标记前驱数量为 -1
		for(int i=1; i<=9; i++)//当前节点的后继节点入度 -1
			if(map[now][i])     indegree[i]--;
	}
	return true;
}

int main() {
	char C[32];
	while(1) {
		scanf("%s",C);
		if(!strcmp(C,"ENDOFINPUT"))	break;//结束测试数据
		
		memset(indegree,0,sizeof(indegree));//数组的初始化
		memset(map,0,sizeof(map));
		int screen[16][16];
		for(int j=0; j<4; j++)
			for(int k=0; k<4; k++)
				scanf("%d",&screen[j][k]);
		scanf("%s",C);
	
		for(int j=1; j<=9; j++) {
			for(int k=0; k<4; k++) {
				int gx=local[j][0]+dx[k];
				int gy=local[j][1]+dy[k];
				int now=screen[gx][gy];//当前屏幕显示的数字
				if(now!=j&&!map[j][now]) {
					map[j][now]=1;
					indegree[now]++;
				}
			}
//				printf("**********\n");
		}

		if(TopoSort())      puts("THESE WINDOWS ARE CLEAN");
		else                puts("THESE WINDOWS ARE BROKEN");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值