HDU 2680 Choose the best route(最短路,反向)

HDU临时网站:http://acm.split.hdu.edu.cn/showproblem.php?pid=2680

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13221    Accepted Submission(s): 4278



Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
  
  
1 -1
 

Author
dandelion
 

Source

题意:

脑袋懵懵的,总感觉最近做题没什么效率了,应该慎重。

回到题目,要去朋友家,又怕晕车,以最短的时间到朋友家,

自家附近的车站有 w 个,(起初译成车站是一个 w)。


思路:

第一次接触反向建图类的最短路,起点很多,但是终点只有一个。


参考CODE:

#include<stdio.h>
#include<cstring>
#include<algorithm>
using namespace std;
const int MYDD=1103;
const int INF=0x3f3f3f3f;

int Map[MYDD][MYDD];
int dis[MYDD];
bool vis[MYDD];
void Dijk(int s,int n) {
	memset(vis,0,sizeof(vis));
	vis[s]=1;
	for(int j=1; j<=n; j++)
		dis[j]=Map[s][j];
	int choose=s;/* *wa_bug注意此时的choose定义在for()之外 */ 
	for(int j=1; j<=n; j++) {
		int Tp=INF;
		for(int k=1; k<=n; k++) {
			if(!vis[k]&&dis[k]<Tp) {
				Tp=dis[k];
				choose=k;
			}
		}
		vis[choose]=1;
		for(int k=1; k<=n; k++) {
			if(!vis[k]&&dis[k]>dis[choose]+Map[choose][k])
				dis[k]=dis[choose]+Map[choose][k];
		}
	}
}

int main() {
	int n,m,s;/*车站数目,路线数,家附近的车站*/
	while(scanf("%d%d%d",&n,&m,&s)!=EOF) {
		for(int j=0; j<=n; j++) /*初始化*/
			for(int k=0; k<=n; k++)
				Map[j][k]=INF;

		for(int j=0; j<m; j++) {
			int p,q,t;/*反向建图*/
			scanf("%d%d%d",&p,&q,&t);
			if(Map[q][p]>t)/*存在多条路线且单向*/
				Map[q][p]=t;
		}

		Dijk(s,n);
		int w;
		scanf("%d",&w);
		int ans=INF;
		while(w--) {
			int dd;
			scanf("%d",&dd);
			if(ans>dis[dd])/*找到最短的一条*/
				ans=dis[dd];
		}

		if(ans==INF)	puts("-1");
		else	printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值