POJ 2533 Longest Ordered Subsequence(最长非递减子序列,LIS)

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 50206 Accepted: 22293

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

题意:

给定的 n 个数,求出从左往右非递减的子序列的最大值

思路:

模板题,就过来水水题的!

AC CODE:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
const int MM = 200100+4;
using namespace std;

int h[MM], d[MM], Ans[MM];

int main()
{
	int n;
	cin >> n;
	for(int i = 1; i <= n; i++) cin >> h[i];

	int ans = 0, vv = 0;
	for(int i = 1; i <= n; i++)
		{
			d[i] = 1;
			for(int j = 1; j <= i-1; j++)
				{
					if(h[j] < h[i] && d[i] < d[j]+1)
						{
							d[i] = d[j] + 1;
						}


				}
			if(d[i] > ans) ans = d[i];
		}

	printf("%d\n", ans);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值