ZOJ_1901 A Star not a Tree?(模拟退火)

A Star not a Tree?

Time Limit: 2000 ms
Memory Limit: 65536 KB
Problem Description

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length.

Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn’t figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub.
Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won’t move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

题意

二维平面内有n个点,求出一个点,使其到所有点的距离和最小。

题解:

模拟退火。先选定一点,枚举若干个方向,向最优的方向移动。特殊一点的是,模拟退火的移动距离不是固定的,而是逐渐缩小的。将范围缩小到一定程度,跳出即可。

#include<stdio.h>
#include<iostream>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<map>
#include<vector>
#include<queue>
#include<iterator>
#define dbg(x) cout<<#x<<" = "<<x<<endl;
#define INF 0x3f3f3f3f
#define LLINF 0x3f3f3f3f3f3f3f3f
#define eps 1e-6
   
using namespace std;
typedef unsigned long long LL;  
typedef pair<LL, int> P;
const int maxn = 220;
const int mod = 2000000007;
int x[maxn], y[maxn];
double solve(int n, double a, double b);
double getans(int n, double a, double b);

int main()
{
    int n, i, j, k;
    double ans = 1e10;
    scanf("%d", &n);
    for(i=0;i<n;i++)
        scanf("%d %d", &x[i], &y[i]);
    for(i=0;i<10;i++)
        ans = min(solve(n, rand()%10000, rand()%10000), ans);
    printf("%.0f", ans);
    return 0;
}

double solve(int n, double a, double b)
{
    double ans = getans(n, a, b);
    for(double i=200000;i>eps;i*=0.8){
        double nx = a, ny = b, as = ans;
        if(getans(n, a+i, b)<as){
            as = getans(n, a+i, b);
            nx = a+i, ny = b;
        }
        if(getans(n, a-i, b)<as){
            as = getans(n, a-i, b);
            nx = a-i, ny = b;
        }
        if(getans(n, a, b+i)<as){
            as = getans(n, a, b+i);
            nx = a, ny = b+i;
        }
        if(getans(n, a, b-i)<as){
            as = getans(n, a, b-i);
            nx = a, ny = b-i;
        }
        a = nx, b = ny, ans = as;
    }
    return ans;
}

double getans(int n, double a, double b)
{
    double ans = 0;
    for(int i=0;i<n;i++)
        ans += sqrt((x[i]-a)*(x[i]-a)+(y[i]-b)*(y[i]-b));
    return ans;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值