[POJ 2420] A Star not a Tree?

A Star not a Tree?
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4058 Accepted: 2005

Description

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length.   Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn't figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub. 
Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won't move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

Source

Waterloo Local 2002.01.26
 
模拟退火算法、网上各种写法、晕死、都不知道哪个是对的了、
数据弱、乱写的、AC了、
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <ctime>
#include <cstdlib>
using namespace std;
#define INF 1e20
#define PI acos(-1.0)
#define N 110

struct Point
{
    double x,y;
    Point(){}
    Point(double x,double y):x(x),y(y){}
};
int n;
Point p[N];

double cal(Point t)
{
    double sum=0;
    for(int i=1;i<=n;i++) sum+=sqrt((p[i].x-t.x)*(p[i].x-t.x)+(p[i].y-t.y)*(p[i].y-t.y));
    return sum;
}
void solve()
{
    int TN=4,DN=100;
    Point u,v,ansp;
    double ud,vd,ansd=INF;
    double step=10000,eps=1e-2,r=0.85;

    while(TN--)
    {
        u=Point(rand()%10000,rand()%10000);
        ud=cal(u);
        while(step>eps)
        {
            bool flag=1;
            while(flag)
            {
                flag=0;
                for(int i=0;i<DN;i++)
                {
                    double d=2*PI*(double)rand()/RAND_MAX;
                    v.x=u.x+sin(d)*step;
                    v.y=u.y+cos(d)*step;
                    vd=cal(v);
                    if(vd<ud) ud=vd,u=v,flag=1;
                }
            }
            step*=r;
        }
        if(ud<ansd) ansd=ud,ansp=u;
    }
    printf("%.0f\n",ansd);
}
int main()
{
    //srand((int)time(NULL)); //POJ上不能用
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++) scanf("%lf%lf",&p[i].x,&p[i].y);
        solve();
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/hate13/p/4472722.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值