POJ 1655 Balancing Act

题目链接:http://poj.org/problem?id=1655


Balancing Act

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 12278
Accepted: 5202

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T.
For example, consider the tree:

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

Source


思路:一道简单的树形DP题。对于每个节点,只要知道它的所有子节点作为一棵子树的节点数和它自己作为子树的节点数,那么以它为根节点,就可以算出它的平衡度,它的父节点作为子树的节点数可以用总数减掉它作为子树的节点数。详见代码。


附上AC代码:

#include <cstdio>
#include <vector>
#include <algorithm>
//#pragma comment(linker, "/STACK:102400000, 102400000")
using namespace std;
const int maxn = 20005;
int dp[maxn], sizev[maxn];
bool vis[maxn];
vector<int> edge[maxn];
int n;

void init(){
	for (int i=1; i<=n; ++i){
		vis[i] = false;
		edge[i].clear();
	}
}

void add_edge(int a, int b){
	edge[a].push_back(b);
	edge[b].push_back(a);
}

void dfs(int u){
	vis[u] = true;
	dp[u] = 0;
	sizev[u] = 1;
	for (int i=0; i<edge[u].size(); ++i){
		int v = edge[u][i];
		if (vis[v])
			continue;
		dfs(v);
		sizev[u] += sizev[v];
		dp[u] = max(dp[u], sizev[v]);
	}
	dp[u] = max(dp[u], n-sizev[u]);
}

int main(){
	#ifdef LOCAL
	freopen("input.txt", "r", stdin);
	freopen("output.txt", "w", stdout);
	#endif
	int T;
	scanf("%d", &T);
	while (T--){
		scanf("%d", &n);
		init();
		int a, b;
		for (int i=1; i<n; ++i){
			scanf("%d%d", &a, &b);
			add_edge(a, b);
		}
		dfs(1);
		int ans=n, res=1;
		for (int i=1; i<=n; ++i)
			if (ans > dp[i]){
				ans = dp[i];
				res = i;
			}
		printf("%d %d\n", res, ans);
	}
	return 0;
}


Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值