UVa524素数环

3 篇文章 0 订阅
2 篇文章 0 订阅


题目位置:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=465


  Prime Ring Problem 

A ring is composed of n (even number) circles as shown in diagram. Put natural numbers $1, 2, \dots, n$ into each circle separately, and the sum of numbers in two adjacent circles should be a prime.


Note: the number of first circle should always be 1.

input

n (0 < n <= 16)

output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements.


You are to write a program that completes above process.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2







#include <stdio.h>
#include <math.h>
#include <string.h>

bool is_p(int x){
	for(int i=2;i<=sqrt(x);i++){
		if(x%i==0) return false;
	}
	return true;
}

int map[20],n;//存数字
bool vis[20]; 
void dfs(int x){
	if(x==n&&is_p(map[0]+map[n-1])){
		printf("%d",map[0]);
		for(int i=1;i<n;i++) printf(" %d",map[i]);
		printf("\n");
	}
	
	for(int i=2;i<=n;i++){
		if(vis[i]==true) continue;
		if(is_p(i+map[x-1])){
			map[x]=i;
			vis[i]=true;
			dfs(x+1);
			vis[i]=false;		
		}
	}	
}

int main(){
	int kase=0;
	while(scanf("%d",&n)!=EOF){
		memset(vis,false,sizeof(vis));
		if(kase) printf("\n"); 
		printf("Case %d:\n",++kase);
		map[0]=1;
		vis[0]=true;
		dfs(1);
	}
	return 0;
}


if(x==n&&is_p(map[0]+map[n-1])){
注意这里,是遇到x==n的时候成立,开始想着判断n-1,然后后面就复杂了……


这里是仿照了n皇后问题,递归只和前面的比较,只要加上最后一次的判断就可以了^_^



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值