HDU4745 Two Rabbits 动态规划

问题描述:

Long long ago, there lived two rabbits Tom and Jerry in the forest. On a sunny afternoon, they planned to play a game with some stones. There were n stones on the ground and they were arranged as a clockwise ring. That is to say, the first stone was adjacent to the second stone and the n-th stone, and the second stone is adjacent to the first stone and the third stone, and so on. The weight of the i-th stone is ai. 

The rabbits jumped from one stone to another. Tom always jumped clockwise, and Jerry always jumped anticlockwise. 

At the beginning, the rabbits both choose a stone and stand on it. Then at each turn, Tom should choose a stone which have not been stepped by itself and then jumped to it, and Jerry should do the same thing as Tom, but the jumping direction is anti-clockwise. 

For some unknown reason, at any time , the weight of the two stones on which the two rabbits stood should be equal. Besides, any rabbit couldn't jump over a stone which have been stepped by itself. In other words, if the Tom had stood on the second stone, it cannot jump from the first stone to the third stone or from the n-the stone to the 4-th stone. 

Please note that during the whole process, it was OK for the two rabbits to stand on a same stone at the same time. 

Now they want to find out the maximum turns they can play if they follow the optimal strategy.


输入:

The input contains at most 20 test cases. 
For each test cases, the first line contains a integer n denoting the number of stones. 
The next line contains n integers separated by space, and the i-th integer ai denotes the weight of the i-th stone.(1 <= n <= 1000, 1 <= ai <= 1000) 
The input ends with n = 0.

输出:

For each test case, print a integer denoting the maximum turns.

样例输入

1

1

4

1 1 2 1

6

2 1 1 2 1 3

0

样例输出:

1

4

5

提示:

For the second case, the path of the Tom is 1, 2, 3, 4, and the path of Jerry is 1, 4, 3, 2. For the third case, the path of Tom is 1,2,3,4,5 and the path of Jerry is 4,3,2,1,5. 
思路:画了3个例子 1 1 2 1;2 1 1 2 1 1;2 1 1 2 1 3;

         
大意是求最长的回文子串,但是是个圈。所以把圈弄成2个相同串。经过上图的灵魂洗礼(= ̄ω ̄=)。显而易见(不难推出,固定搭配,语感233333)发现所求的结果就是把串分成2个区间,分别求2个区间最大回文子串的长度然后求和就行了。转移方程:if(a[i]==a[j]) dp[i][j]=dp[i+1][j-1]+2;//2个方向扩展,相同自然构成回文,长度+2;
   else dp[i][j]=max(dp[i+1][j],dp[i][j-1]);//i j不同就选i+1到j和i到j-1最大的。。

AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
const int maxn=1007;
int dp[maxn][maxn];
int a[maxn];
int main()
{
    int n;
    while(cin>>n)
    {
        if(n==0) break;
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
        }
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
            dp[i][i]=1;
        for(int i=n;i>=0;i--)
        {
            for(int j=i+1;j<n;j++)
            {
                if(a[i]==a[j])
                    dp[i][j]=dp[i+1][j-1]+2;
                else
                    dp[i][j]=max(dp[i+1][j],dp[i][j-1]);
            }
        }
        int ans=dp[0][n-1];
        for(int i=0;i<n-1;i++)
            ans=max(ans,dp[0][i]+dp[i+1][n-1]);
        cout<<ans<<endl;

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值