BFS:题目1456:胜利大逃亡

1 篇文章 0 订阅
本文深入探讨了BFS(广度优先搜索)算法,并通过一个具体的题目1456——胜利大逃亡进行实战解析,详细阐述了如何利用BFS解决路径寻找问题,帮助读者理解并掌握这一重要的图论算法。
摘要由CSDN通过智能技术生成

题目1456:胜利大逃亡

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:4640

解决:1693

题目描述:

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

输入:

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙。

输出:

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

样例输入:
1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0 
样例输出:
11


//ac.jobdu.com/problem.php?pid=1456
#include<cstdio>
#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
#include<cctype>
#include<algorithm>
#include<vector>
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<fstream>
using namespace std;
const int maxn=10000;
int X[6]={0,0,0,0,1,-1};
int Y[6]={0,0,1,-1,0,0};
int Z[6]={1,-1,0,0,0,0};
bool vis[51][51][51]={false};
int maze[51][51][51]={};
int n,m,t,T;
bool test(int x,int y,int z){
	if(x<0 || x>=n||y<0||y>=m||z>=t||z<0|| maze[x][y][z]==1)
		return false;
	return true;
}
struct node{
	int x, y,z;
	int step;//一定要定义为node的成员,节点运动中记录着步数。
};
int bfs(int n,int m,int t){
	queue<node> q;
	node st;
	st.x=0;
	st.y=0;
	st.z=0;
	vis[0][0][0]=true;
	st.step=0;		//若单独定义step无法与走到的节点处的真实步数保持一致
	q.push(st);

	while(!q.empty()){
		node top=q.front();
		q.pop();
		if(top.x==n-1 && top.y==m-1 && top.z==t-1)
			return top.step;
		for(int i=0;i<6;i++){
			int nx=top.x+X[i];
			int ny=top.y+Y[i];
			int nz=top.z+Z[i];
			int nstep=top.step+1; //不可写成++;
			if(test(nx,ny,nz)){
				node nt;
				nt.x=nx;
				nt.y=ny;
				nt.z=nz;
				nt.step=nstep;
				if(vis[nx][ny][nz]==false){
					vis[nx][ny][nz]=true;
					q.push(nt);
					//cout<<nx<<" "<<ny<<" "<<nz<<" "<<nstep<<endl;
				}
			}
		}
	}
	return -1;
}
int k;
int main(){
#ifdef _DEBUG
	ifstream cin("a.txt");
#endif
	cin>>k;
	while(k--){
		memset(vis,false,sizeof(vis));
		cin>>n>>m>>t>>T;
		for(int x=0;x<n;x++){
			for(int y=0;y<m;y++)
				for(int z=0;z<t;z++)
					cin>>maze[x][y][z];
		}
	
		int ans=bfs(n,m,t);
		if(ans>T)
			cout<<"-1"<<endl;
		else
			cout<<ans<<endl;
	}
#ifdef _DEBUG
	cin.close();
#endif
	return 0;
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值