SDAU 搜索专题 04 射箭

1:问题描述
Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object’s coordinates, please calculate the angle between the arrow and x-axis at Bob’s point. Assume that g=9.8N/m.

Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow’s exit speed.
Technical Specification

1. T ≤ 100.
2. 0 ≤ x, y, v ≤ 10000.

Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output “-1”, if there’s no possible answer.

Please use radian as unit.

Sample Input
3
0.222018 23.901887 121.909183
39.096669 110.210922 20.270030
138.355025 2028.716904 25.079551

Sample Output
1.561582
-1
-1

2:大致题意

给你一个坐标轴,你在坐标原点上,然后再给你一个苹果的坐标(x,y)。
最后给你箭射出去的初速度,让你调整角度,以便可以射到苹果。

3:思路

直接写出运动轨迹方程,求出夹角就行了。
x=v*cos(a)*t。
y=v*sin(a)+g*t*t*(0.5)。
消去t可以得到一个一元二次方程。解出来就可以了。

4:感想

一开始用二分法没有做出来,最后列的数学表达式。。。

5:ac代码

#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
#include<iomanip>
#include<cstdio>
using namespace std;
int main()
{
    int n,m,j;
    double v,x,y,t,a,b,c,x1,x2;
    cin>>n;
    double g=9.8;
    while(n--)
    {
        cin>>x>>y>>v;
        a=x*x*g/(2*v*v);
        b=-1*x;
        c=y+a;     //费了好大劲才算出来。
        t=b*b-4*a*c;
        if(t<0) cout<<"-1"<<endl;
        else
        {
            x1=(-1*b-sqrt(t))/(2*a);
            x2=(-1*b+sqrt(t))/(2*a);
            if(x1>=0)
            {
                if(x2>=0)
                x1=min(x1,x2);
                cout<<fixed<<setprecision(6)<<atan(x1)<<endl;
            }
            else if(x2>=0) cout<<fixed<<setprecision(6)<<atan(x2)<<endl;
            else
            cout<<"-1"<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值