1:问题描述
Problem Description
In a two-dimensional plane there are two line belts, there are two segments AB and CD, lxhgww’s speed on AB is P and on CD is Q, he can move with the speed R on other area on the plane.
How long must he take to travel from A to D?
Input
The first line is the case number T.
For each case, there are three lines.
The first line, four integers, the coordinates of A and B: Ax Ay Bx By.
The second line , four integers, the coordinates of C and D:Cx Cy Dx Dy.
The third line, three integers, P Q R.
0<= Ax,Ay,Bx,By,Cx,Cy,Dx,Dy<=1000
1<=P,Q,R<=10
Output
The minimum time to travel from A to D, round to two decimals.
Sample Input
1
0 0 0 100
100 0 100 100
2 2 1
Sample Output
136.60
2:大致题意
给出ABCD的坐标,和在 AB,CD,其他线段,上的移动速度。要求出从A到D的最短时间。
3:思路
每次三分AB的时候,都要通过3分法得到CD上的最优解。
路线一定是 这样的。 从 A开始 到 AB 上的 o 点,再到 cd 上的 n 点,最后到达 D 。 其中Ao nD 都可以为 0 。
列出表达式 Ao / p + on /v +nD/q。
4:感想
要双向3分。每次三分AB的时候,都要通过3分法得到CD上的最优解。
好难啊啊啊啊。参考的别人的博客。
5:ac代码
#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
#include<iomanip>
#include<cstdio>
using namespace std;
struct point
{
double x,y;
};
int p,q,r,v;
double dis(point a,point b)
{
return pow(pow(a.y-b.y,2)+pow(a.x-b.x,2),1.0/2);
}
double findy(point c,point d,point y)
{
point mid,midmid,left,right;
double t1,t2;
left = c;
right = d;
do
{
mid.x = (left.x+right.x)/2;
mid.y = (left.y+right.y)/2;
midmid.x = (right.x+mid.x)/2;
midmid.y = (right.y+mid.y)/2;
t1 = dis(d,mid)/q+dis(mid,y)/r;
t2 = dis(d,midmid)/q+dis(midmid,y)/r;
if(t1>t2)
left = mid;
else right = midmid;
}while(fabs(t1-t2)>0.000001);
return t1;
}
double find(point a,point b,point c,point d)
{
point mid,midmid,left,right;
double t1,t2;
left = a;
right = b;
do
{
mid.x = (left.x+right.x)/2;
mid.y = (left.y+right.y)/2;
midmid.x = (right.x+mid.x)/2;
midmid.y = (right.y+mid.y)/2;
t1 = dis(a,mid)/p+findy(c,d,mid);
t2 = dis(a,midmid)/p+findy(c,d,midmid);
if(t1>t2)left = mid;
else right = midmid;
}while(fabs(t1-t2)>0.000001);
return t1;
}
int main()
{
int t;
point a,b,c,d;
scanf("%d",&t);
while(t--)
{
scanf("%lf%lf%lf%lf %lf%lf%lf%lf",&a.x,&a.y,&b.x,&b.y,&c.x,&c.y,&d.x,&d.y);
scanf("%d%d%d",&p,&q,&r);
printf("%.2f\n",find(a,b,c,d));
}
return 0;
}