hdu3496 Watch The Movie(二维01背包)

问题描述:
Problem Description
New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.
DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.
But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L.
How clever you are! Please help DuoDuo’s uncle.

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:
The first line is: N(N <= 100),M(M<=N),L(L <= 1000)
N: the number of DVD that DuoDuo want buy.
M: the number of DVD that the shop can sale.
L: the longest time that her grandfather allowed to watch.
The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.

Output

        Contain one number. (It is less then 2^31.)

The total value that DuoDuo can get tonight.
If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.

Sample Input
1
3 2 10
11 100
1 2
9 1

Sample Output
3

大致题意:
朵朵想看电影。
n是朵朵想看的电影个数,m是商店卖的数量,不能多也不能少。L是她家长让看的时间。
每个电影有时间和对于朵朵的价值。
现在朵朵想在有限的时间内看m个电影,并且使价值最大。求出最大价值。

思路分析:
2维的01背包。
因为电影数必须为m所以初始化的时候要注意。这就相当于要装满背包。
要求恰好装满背包,那么在初始化时除了F[0]为0,其 它F[1..V ]均设为−∞,这样就可以保证最终得到的F[V ]是一种恰好装满背包的 最优解。 如果并没有要求必须把背包装满,而是只希望价格尽量大,初始化时应该 将F[0..V ]全部设为0。 这是为什么呢?可以这样理解:初始化的F数组事实上就是在没有任何物 品可以放入背包时的合法状态。如果要求背包恰好装满,那么此时只有容量 为0的背包可以在什么也不装且价值为0的情况下被“恰好装满”,其它容量的 背包均没有合法的解,属于未定义的状态,应该被赋值为-∞了。如果背包并非 必须被装满,那么任何容量的背包都有一个合法解“什么都不装”,这个解的 价值为0,所以初始时状态的值也就全部为0了。

dp[i][j]代表的就是看i个电影时间为j的情况下的最大价值。
ac代码:

#include<bits/stdc++.h>
using namespace std;
int T,n,m,l;
#define INF 999999
struct Node
{
    int time;
    int value;
}a[105];
int dp[105][2005];
int main()
{
    ios::sync_with_stdio(false);
    cin>>T;
    while(T--)
    {
        int i,j,k;
        cin>>n>>m>>l;
        for(i=0;i<n;i++)
        {
            cin>>a[i].time>>a[i].value;
        }
        for(i=0;i<=m;i++)
            for(j=0;j<=l;j++)
            {
                if(i==0)
                    dp[i][j]=0;
                else
                    dp[i][j]=-INF;
            }
        for(i=0;i<n;i++)
        {
            for(k=m;k>=1;k--)
            {
                for(j=l;j>=a[i].time;j--)
                {
                    dp[k][j]=max(dp[k][j],dp[k-1][j-a[i].time]+a[i].value);
                }
            }
        }
        if(dp[m][l]<0)
            dp[m][l]=0;
        cout<<dp[m][l]<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值