hdu1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 322950    Accepted Submission(s): 62743


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


代码有详细注释,感觉这个好理解
#include<iostream>
#include<cstdio>
#include<cstring>

int main()
{
	char str1[1001], str2[1001];
	int t, i, len_str1, len_str2, len_max, num = 1, k;
	scanf("%d", &t);
	while (t--)
	{
		int a[1001] = { 0 }, b[1001] = { 0 }, c[1001] = { 0 };
		scanf("%s", str1); //输入第一个数
		len_str1 = strlen(str1);          //算出str1的长度,不包括‘\0’
		for (i = 0; i <= len_str1 - 1; ++i)       //将str1的值逆序赋值给a
			a[i] = str1[len_str1 - 1 - i] - '0';
		scanf("%s", str2);       //输入第二个大数
		len_str2 = strlen(str2);   
		for (i = 0; i <= len_str2 - 1; ++i)      //将str2的值逆序赋值给b
			b[i] = str2[len_str2 - 1 - i] - '0';
		if (len_str1>len_str2)     //判断谁的长,长度长的复制到len_max
			len_max = len_str1;
		else
			len_max = len_str2;
		k = 0;
		for (i = 0; i <= len_max - 1; ++i)
		{
			c[i] = (a[i] + b[i] + k) % 10;   //取每位上两个数相加的个位和
			k = (a[i] + b[i] + k) / 10;  //将两数相加的十位数赋值到k
		}
		if (k != 0)      //如果k还有剩余,说明数组c还有一位,且不超过1
			c[len_max] = 1;
		printf("Case %d:\n", num);
		num++;
		printf("%s + %s = ", str1, str2);
		if (c[len_max] == 1)      //输出最高位
			printf("1");
		for (i = len_max - 1; i >= 0; --i)
		{
			printf("%d", c[i]);
		}
		printf("\n");
		if(t>=1)
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值