L2-006. 树的遍历
时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越
给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
#include <cstdio>
#include <queue>
#include <algorithm>
using namespace std;
int pre[1100];
int in[1100];
int l[1100],r[1100];
int post(int root, int start, int end) {
if(start > end)
return 0;
int s=pre[root];
int i = start;
while(i < end && in[i] != pre[root]) i++;
l[s]=post(root - 1 + i-end, start, i - 1);
r[s]=post(root - 1 , i + 1, end);
return s;
}
int print(int s)
{
queue<int>Q;
Q.push(s);
while(!Q.empty())
{
int a=Q.front();
Q.pop();
if(a!=s) printf(" ");
printf("%d",a);
if(l[a])
Q.push(l[a]);
if(r[a])
Q.push(r[a]);
}
printf("\n");
}
int main() {
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&pre[i]);
for(int i=0;i<n;i++)
scanf("%d",&in[i]);
post(n-1,0,n-1);
print(pre[n-1]);
system("pause");
return 0;
}
下面给出由前序遍历和中序遍历求层序遍历,只需改动红色部分即可;
#include <cstdio>
#include <queue>
#include <algorithm>
using namespace std;
int pre[1100];
int in[1100];
int l[1100],r[1100];
int post(int root, int start, int end) {
if(start > end)
return 0;
int s=pre[root];
int i = start;
while(i < end && in[i] != pre[root]) i++;
l[s]=post(root +1, start, i - 1);
r[s]=post(root +1+i-start , i + 1, end);
return s;
}
int print(int s)
{
queue<int>Q;
Q.push(s);
while(!Q.empty())
{
int a=Q.front();
Q.pop();
if(a!=s) printf(" ");
printf("%d",a);
if(l[a])
Q.push(l[a]);
if(r[a])
Q.push(r[a]);
}
printf("\n");
}
int main() {
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&pre[i]);
for(int i=0;i<n;i++)
scanf("%d",&in[i]);
post( 0 ,0,n-1);
print( pre[0] );
system("pause");
return 0;
}
#include <queue>
#include <algorithm>
using namespace std;
int pre[1100];
int in[1100];
int l[1100],r[1100];
int post(int root, int start, int end) {
if(start > end)
return 0;
int s=pre[root];
int i = start;
while(i < end && in[i] != pre[root]) i++;
l[s]=post(root +1, start, i - 1);
r[s]=post(root +1+i-start , i + 1, end);
return s;
}
int print(int s)
{
queue<int>Q;
Q.push(s);
while(!Q.empty())
{
int a=Q.front();
Q.pop();
if(a!=s) printf(" ");
printf("%d",a);
if(l[a])
Q.push(l[a]);
if(r[a])
Q.push(r[a]);
}
printf("\n");
}
int main() {
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&pre[i]);
for(int i=0;i<n;i++)
scanf("%d",&in[i]);
post( 0 ,0,n-1);
print( pre[0] );
system("pause");
return 0;
}