树形DP

DP变种

记:第一次在POJ上提交题目,对Java开发者及其不友好~~,直接编译错误了。


Anniversary party

Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
Output should contain the maximal sum of guests’ ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
5

简单来说,领导不能和下属坐在一起,否则聚会的快乐值要减少,怎么保证整个聚会的快乐值最大?输入的第一行是所有员工个数,第二个是每个员工的快乐值,第三栏是直属领导关系,比如 2,3表示员工号3是2的领导。

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

/**
 * @author Q
 * @create 2020/10/6
 */
public class Main {
    int maxn = 6000;
    List<Integer>[] g = new ArrayList[maxn];
    int[] rating;
    int[][] memo = new int[maxn][2];
    int[] parent = new int[maxn];
    int rt;
    public void dfs(int u){
        int sz = g[u].size();
        memo[u][1] = rating[u];
        for(int i = 0; i<sz; i++){
            int v = g[u].get(i);
            dfs(v);
            memo[u][1] += memo[v][0];
            memo[u][0] += Math.max(memo[v][1], memo[v][0]);
        }
    }

    public void solve() {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        rating = new int[n];
        for(int i = 0; i<n; i++){
            rating[i] = sc.nextInt();
        }
        sc = new Scanner(System.in);
        for(int i = 0; i<maxn; i++) g[i] = new ArrayList<>();
        for(int i = 0; i<n; i++){
            int a = sc.nextInt();
            int b = sc.nextInt();
            parent[a] = b;
            g[b].add(a);
        }
        for(int i = 0; i<n; i++){
            if(parent[i] == 0) {
                rt = i;
                break;
            }
        }
        dfs(rt);
        System.out.println(Math.max(memo[rt][0], memo[rt][1]));
    }
    public static void main(String[] args) {
        new Main().solve();
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值