HDU1262 Tickets(水)

Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6649    Accepted Submission(s): 3426


Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
 

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
 

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
 

Sample Input
 
 
2 2 20 25 40 1 8
 

Sample Output
 
 
08:00:40 am 08:00:08 am
 
比较简单的一道dp。

题意是可以两个人同时买票也可以一个一个买,让你求出买票所需最短的时间。

dp[i]表示已经有n个人买票时的最短时间。

i从1循环到k

分别更新dp[i+1]和dp[i+2]

最后dp[k]即为所需要最短时间(秒为单位)

最后按要求输出即可

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <string>
#include <iostream>
#include <math.h>
#include <queue>
#include <vector>
#include <climits>
using namespace std;
const int maxn = 2e3 + 10;
int single[maxn];
int both[maxn];
int dp[maxn];
int n,m;
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int k;
        cin>>k;
        for(int i = 1; i <= k; i++)
            cin>>single[i];
        for(int i = 1; i <= k - 1; i++)
            cin>>both[i];
        memset(dp,1,sizeof(dp));
        dp[0] = 0;
        for(int i = 1; i <= k; i++)
        {
            dp[i] = min(dp[i],dp[i-1] + single[i]);
            if(i == k)break;
            dp[i+1] = min(dp[i+1],dp[i-1] + both[i]);
        }
        int h = dp[k]/3600 + 8;
        dp[k] %= 3600;
        int m = dp[k]/60;
        dp[k] %= 60;
        printf("%02d:%02d:%02d ",h%12,m,dp[k]);
        if(h > 12) puts("pm");
        else puts("am");
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值