Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
Sample Output
EMPTY QUEUE!
msg2 10
msg1 10
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
Sample Output
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!
题意描述:
输入 command,当为PUT时,存入数据,GET时,按优先由小到大输出一个,如果没有时,输出empty queue!
解题思路:
采用优先队列,自己定义,优先数小的先输出放在队首,因为数量过大,注意运用scanf和printf来提高运行效率!否则会超时!
代码:
#include<bits/stdc++.h>
using namespace std;
struct message
{
char name[100];
int data;
int priority;
bool operator < (const message &a) const
{
return a.priority<priority;
}
};
priority_queue<message> v;
int main()
{
char t[100];
message a;
while(scanf("%s",t)!=EOF)
{
if(strcmp(t,"GET")==0)
{
if(v.size()==0)
printf("EMPTY QUEUE!\n");
else
{
printf("%s %d\n",v.top().name,v.top().data);
v.pop();
}
}
else if(strcmp(t,"PUT")==0)
{
scanf("%s%d%d",&a.name,&a.data,&a.priority);
v.push(a);
}
}
return 0;
}
心得:
题目较为新鲜,注意运用scanf和printf!