P - 16

Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.


Input


The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.


Output


For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.


Sample Input


5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1


Sample Output


13.333

31.500

题意描述:

给定特定数量豆子,用来换猫食,但并不能全部换,f*a%只能得到j*a%,让你输出最大可以换到多少猫食!

解题思路:

建立结构体,用来存放 a,f,j,用j/f来确定a,首先应该找a大的,a越大换的越多,如果a相同,那么找f大的,直到m为0!注意最后一个数据的处理,应该加上 它m*a.同时,还需要重载运算符!

代码:

#include <iostream>
#include <iomanip>
#include <vector>
#include <algorithm>
using namespace std;
struct mouse{
    double j;
    double f;
    double a;
}m;
bool comp(const mouse &d1,const mouse &d2)
{
	if(d1.a!=d2.a)
	return d1.a>d2.a;
	else return d1.f<d2.f;
}
    int main()
{
    int i,n,d;
    double sum;
    vector<mouse>v;
    while(cin>>d>>n)
    {
        v.clear();
        sum=0.0;
        if(d==-1&&n==-1)
        break;
        for(i=0;i<n;i++)
        {
            cin>>m.j>>m.f;
            m.a=m.j/m.f;
        v.push_back(m);
        }
       sort(v.begin(),v.end(),comp);
       for(i=0;i<v.size();i++)
       {
       	if(d>=v[i].f)
       {	sum+=v[i].j;
       	d=d-v[i].f;
       }
       else {
       	sum+=d*v[i].a;
       	break;
       }
       }
       cout<<fixed<<setprecision(3)<<sum<<endl;
    }
    return 0;
}

心得:

分析问题应该全面,与数学建立联系,比如求a和怎么样得到a的最大值,均需要数学考虑!仔细分析!沉着应对!


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值